PDA

View Full Version : electrical question PLEASE HELP!!!



needthat25
02-27-2012, 08:00 PM
ok first off i dont no if i am posting in the correct are but please move if not thank u!!!! now here is the problem i bought a high output altenator from db electrical about a year ago i dont no if its not working properly maybe i have it hooked up wrong or whatever the case maybe....i have 3 runs of 0 guage from the alt to the d3400 battery in the front and then 2 runs of 0 guage from the pos of the d3400 to the battery in the back which is a d3100 and its then connected with 1 run of 0 guage to the 50 farad cap then to the amp and it sounds like ****!!! i set the sub amp with the smd dd-1 it just seems the batterys are not being charge back up....the amp is a re audio xtx 5000.1 i just dont get it the batteries should have this amp covered it says on the d3100 alone 4000-5000 watts rms???? so whats my problem???? i been looking at the mechman altenators do u this this will solve my problem???? do u think my battery bank is too small??? and thanks to all that could help me figure this out!!!

MANTI5
02-27-2012, 08:01 PM
What car?

needthat25
02-27-2012, 08:03 PM
2003 malibu!! sorry

schackel
02-27-2012, 08:05 PM
do you have a big ground wire or two from negative on your batteries to the chasis?

ngsm13
02-27-2012, 08:07 PM
Use a DMM to check the voltage with the car on an off, check at the batteries and the amp.

needthat25
02-27-2012, 08:17 PM
yes i do i have 2 of them i believe 1 from the chassis to the battery and the motor to the battery but i did not put one from the alt to the chassis (i dunno if this makes a difference)

needthat25
02-27-2012, 08:23 PM
when i charge the batteries they read about 15.3 with it off its about 14.4 14.2 right now thier 13.8 sitting with the car running its about 14.5 14.6 i noticed when i charged the batteries the voltage doesnt drop as much while stereo is on but now they dropping below 13 volts but if i put the charger on it it wont drop below 14 for a few days then its this low volatage which just say to me that their not being kept up at full charge correct me if i am wrong???

needthat25
02-27-2012, 09:49 PM
i moved this to where i think ill get more help thanks!!!