PDA

View Full Version : Any good places that fix HU's??? Bad situation for me.



n8te81
11-23-2011, 06:03 PM
I bought a pio 4300 last week from a seller off of ebay, unit was brand new but you know its not covered by pioneer cause they dont like dealing with ebay. Well this week I had a guy with a shop install it. About 3 hours later the deck just went out....after a day of asking questions and looking everything over come to find out that he hooked the pos and neg speaker wires up on the harness when i had an amp and that cause the deck to shut off. He is denying he did anything wrong and i dont know what to do but i dont have the money to buy another one. Is there a place i can send it to that wont cost alot to fix it???

Im just really frustrated and dont know what to do but maybe take this guy to small claims court but im not sure it would be worth the hassle.

whitedragon551
11-23-2011, 06:06 PM
Id make him fix it.

If you paid with a credit card do a charge back. If you paid with a check cancel it. Contact BBB.

Other than that United Radio does it. They are certified to do it and cost an arm and a leg.

n8te81
11-23-2011, 06:16 PM
Well the only thing i could do was do a dispute with the bank to get the money back i paid to have him install it which was 70 and thats going on right now. With the seller they said since it was him that messed it up it was his responsibility and that they couldnt warranty it. He is denying anything that he did wrong and saying it was right but i took it to 2 other places and they said what idiot did this. I just feel so screwed on this and i shouldnt be.

Bettr n' Revrse
11-23-2011, 06:53 PM
Can you get written claims for those to other shops? I can't beleive he charged you 70 bucks!

IonRL205
11-23-2011, 07:03 PM
Did you check and see if you blew the fuse on your deck?

n8te81
11-23-2011, 07:10 PM
I have to get a written statement from a guy i know at another shop to get the dispute going which is no big deal cause he said he would. Only reason i went to this guy in the first place was cause he wanted half the money everyone else did for a simple install. Everyone else here quoted me 150+ since it was a double din. I should have just done it myself but i thought since it was a double that there would be diff wires but nope.

I cut all the wires leaving just the main red,black and yellow and it was still popping the fuse in the back of the HU and not turning on so it has to be the deck im assuming.

TheUnderFighter
11-23-2011, 08:08 PM
So you thought there'd be different wires.... like just connecting more wires? Haha, it's all color coded, just match the colors! Bummer to hear man.

n8te81
11-23-2011, 08:11 PM
So i felt uncomfortable doing it in my 350z of messing something up.....so sue me. Im sure alot of ppl are the same way that dont know everything about car audio. I dont think its very funny but whatever, now that i know i could have done it i should have but i didnt and yeah i regret it now all the time.

TheUnderFighter
11-24-2011, 11:26 PM
Wires are wires man, they're all color coded, especially in any newer car... I don't know how you could fail to see the humor in it.