PDA

View Full Version : Alpine iDA-X305 "USB Device Error"



badlandz
09-29-2011, 05:08 AM
Saw this exact thread before (tread was closed without an answer), did the same thing, googled, didn't find any answers.

I assumed that the Alpine cable was special to work with the iDA-X305, because when it WAS working, I tried to replace it with a shorter standard USB cable, and it wouldn't work with my iPhone or my iPod.

Eventually the clasp on the Alpine cable wore out, and I started to get the USB Device Error message. So, I tried a half dozen standard usb to iPod cables with no luck. Then ordered a "special" one on eBay, and got shipped a standard USB cable! That cost 3x the price of what it should, and it didn't work.

So, is the firmware in my head unit messed up? Is it a special cable? Does the latest iPhone 4 firmware not work with the head unit? (if the last is the answer, it doesn't explain why my old 60G iPod stopped working).

Has anyone figured this out? I've seen it come up a number of times, but I don't see the answers.