View Full Version : Civic SI engine swap idle problem

07-11-2011, 12:55 PM
Alright i have a 1999 civic si with a b18b block and gsr head so its ls-vtec. WHen i cold start it it does not want to idle and there is a strong smell of gas. Could the problem be air/fuel ratio? Once the car is warmed up a little it idles perfect and you can shut it off and restart it without a problem. Any help is appreciated

07-28-2011, 11:24 PM
no car guys?

07-28-2011, 11:42 PM
Have u checked for vacuum leaks? Have u checked ur fpr? what about ur egr?

07-29-2011, 12:08 AM
Stock throttle body?throttle position sensor?

07-29-2011, 12:21 AM
What ecu ? P28 or stock p2p

Still have knock sensor ?

---------- Post added at 09:21 PM ---------- Previous post was at 09:20 PM ----------

I also forgot which 2 plugs look identical but u might have reversed them

07-29-2011, 12:30 AM
I still say its an egr issue

07-29-2011, 12:30 AM
You've came to the right place... Lord knows there aren't any civic forums on the interwebzz.

07-29-2011, 07:54 PM
have you resolved your problem sir:readytog:

I Like Waffle
08-02-2011, 10:45 PM
Might be some rice clogging one of your injectors.

08-02-2011, 10:49 PM
Might be some rice clogging one of your injectors.

fuqq yo waffle *****

08-02-2011, 10:49 PM
pin point where the gas smell comes from?

08-02-2011, 11:07 PM
Unless you've got the ecu retuned it won't run right, i'd invest in hondata if I were you.

08-05-2011, 09:54 PM
sorry guys havent checked here in awhile. Its a stock ecu an its been relocated to the glove box for whatever reason idk. To resolve problems you are talking about would i need to take it in somewhere or are there tests i can do to narrow it down?