PDA

View Full Version : IVA-D106 Touchscreen issue on navigation



Stubb063
05-27-2011, 02:39 PM
I bought this head unit last year for my car. Overall, it's worked well, but just had a pretty serious issue spring up this week. The touchscreen works absolutely fine when the audio controls are displayed. But when I switch the display to the navigation view, the touchscreen becomes completely unresponsive. I can't tap any of the soft buttons on the touch screen, or really interact with the screen in any way.

But, like I said, everything works perfectly fine when I switch back to the audio display.

Anyone ever hear of this? I've tried researching this on Google, but haven't found anything. It seem pretty obvious that it's not a problem with the touchscreen itself, but probably a problem with the software. I'm hoping someone has heard of a way to bypass this glitch and get it going again.

Thanks in advance for any help.

EDIT: I should also mention that the Navigation, with the exception of the interface, works fine. It still shows my current position, moves when the car moves, etc. So the screen isn't frozen. I'm just not able to tap anything, which means I can't enter a destination, which pretty much makes the navigation worthless.

vaiboy
05-27-2011, 04:44 PM
Be sure the connections on the RGB cable between the head unit and nav unit are secure, it could be a bad RGB cable.

Stubb063
05-31-2011, 01:16 PM
Thanks for the response.

Everything looked good to me. If a wire was loose, wouldn't the problem be consistent no matter what view (Nav or Audio) the software was showing?

Just seems like a really weird problem.

vaiboy
05-31-2011, 03:46 PM
In audio mode the touchscreen is controlling functions that are on-board the head unit. In navigation mode the touchscreen sends signals through the RGB cable to control functions on the nav unit. Since the touchscreen is functional and the nav unit isn't frozen and seems the control signals between the head unit and nav are being lost. The RGB cable is the only link between your head unit and your nav so it's the most likely cause. If the connections at both ends of the cable seem secure you might try inspecting the entire length of the cable between the two units. I don't know exactly how long your cable is but it could be nearly 20 ft long and one bad kink or pinch could be enough to screw it up.