PDA

View Full Version : Greetings, From Minnesota.



Steven Fuchs
03-02-2011, 12:27 PM
My name is Steve, pretty new to the car audio world and would quickly like to advance to a better system. Right now I am having trouble with my amp continuing to overload while it is bridged.

"System" includes.
2 infinity ref. series 1252w 12" subs
1 750w sony x-plod amp
Roadmaster's VR3 VRCD400SDU cd-deck

and the usual cheap walmart wiring-kit which i believe is a 14g wiring.

feel free to give me any advice on how to fix this overloading issue. When I have both subs hooked up they do not receive enough power and does not hit as hard as I want.
When I have one sub hooked up and bridged with the amp it hits a lot harder but always gives me the overloading issue right away or blows out the fuse inside the amp. (I've gone threw 6 fuses this week.)


thanks STeve.

MONSONwarrior
03-02-2011, 12:30 PM
Well would you be willing to just completely upgrade or do you want to keep the equipment you have?

If you wanna keep the equipment you have I'd say order a 4 gauge kit from http://www.knukonceptz.com/ rewire everything. What are the impedance of your subs? If you're going to bridge a 2 channel they will need to be single 2 ohm or dual 4, so you may just have your amp wired too low so it's going into protect. That thing is probably barely stable at 4 ohms let alone 2.

If you need any help just send me a PM and I'm about an hour and a half drive from where you are so I may be able to help you get stuff set up if you decide to just upgrade everything.

dragnix
03-02-2011, 12:39 PM
maybe check your connections. If you're blowing fuses then there might be a bad connection somewhere. But it's a sony xplod, it could just be doing what the name states.

AlterEgo99
03-09-2011, 08:58 PM
Welcome to Hell.

http://i854.photobucket.com/albums/ab110/6crnbnh/1234567890/HPD-Hell.jpg