PDA

View Full Version : Help installing Clarion equalizer?



nstillmatic
10-20-2010, 07:06 AM
I'm having some problems with my new Clarion EQS746. I'm trying to hook it up to my Pioneer AVH-P4200DVD headunit. This is how I have it connected:

Lows amp->sub out on equalizer
Highs amp->front out on equalizer

Then from eq's main input, I have that connected to the headunits R/L front outputs. Is this correct? Because all I get is very low distortion, no audible sound. The speakers and amps are working correctly, because If I plug everything directly into the headunit (bypassing the eq) the speakers work fine. Any help appreciated

Sarthos
10-20-2010, 12:01 PM
Since you have a low amp and a high amp I assume you mean you're running an active setup on the front stage?

It sounds like your Clarion isn't working, I'm not familiar with the model, but do you have the master volume on it set right? and are you positive it has power going to it? A loose wire or something would make it not turn on and not put out any sound.

nstillmatic
10-20-2010, 12:34 PM
I have the Polk MM6501's on the front stage, so I still have the passive crossover hooked up. I'm pretty sure the EQ is getting power because the blue lighting turns on, however the sound outputting from the speakers sounds the same whether or not the 12v wire is even connected to it. And yes, I've adjusted the volume knob, it just makes the noise louder.

The 12v is wired straight to the battery.

Ridinhi
10-20-2010, 03:36 PM
Clarion EQS746 7-Band Equalizer/EQ (EQS-746) (http://www.sonicelectronix.com/item_6655_Clarion+EQS746.html)
this the one you have?

nstillmatic
10-20-2010, 09:20 PM
Yes