PDA

View Full Version : further experimentation with my kenwood head unit problem



skylineTT
08-03-2010, 12:26 AM
Its the KDC-689. a great unit that flips the face when the car is off, flips it back when the car is on, and slides the bottom out to insert discs.. you get the picture.

well previously i had tested it on 12v and the display would not light up, but the face would flip when given power. i pulled the good unit out of my car and installed this one for further testing and found that the display lights up while the face is out (when ignition is on), and then goes out when the face flips back to normal position. i then turned the key off and it would slide out and back to flipped (hidden) position. what i did next, was turn the key on and let it slide forward, then i held the face there so that it couldnt flip back.. the display would stay on and read standby. none of the buttons would do anything but the display stayed on. then i would let it start to move a tad and i would quickly press the SRC button to turn the tuner on and hold it again to make it stay in the standby position but now the tuner stayed on and i could turn the volume meter up and down. the radio functions would not work thouth (because it was in standby mode).. so i would let it slip a little more and i would press the other bottons and the functions would work but then it would shut off after finised sliding.

The only way it will stay on is if i hold the face out then it cuts out when the face slides up.

Does anybody know why this could be happening? i would like to use this unit if i can get it workin.