PDA

View Full Version : kenwood HU Problem



skylineTT
05-25-2010, 04:13 AM
i bought this HU secondhand and got a great deal on it. when i power it up, the face will tilt downward, but i cant turn the display on. then it will randomly tilt back up but still cant power. tried the little reset button, and holding every single button on the face to turn it on. cant figure it out though. is there a weird process with these?

its the kenwood kdc-x689.. looks to be a very high dollar HU and i like the specs. let me know! thanks

swollen_cu
05-25-2010, 03:52 PM
I had a similar problem with my old kenwood headunit.. I tried everythign to make it work, but it would just work randomly.

ahole-ic
05-25-2010, 03:57 PM
i bought this HU secondhand and got a great deal on it. when i power it up, the face will tilt downward, but i cant turn the display on. then it will randomly tilt back up but still cant power. tried the little reset button, and holding every single button on the face to turn it on. cant figure it out though. is there a weird process with these?

its the kenwood kdc-x689.. looks to be a very high dollar HU and i like the specs. let me know! thanks
I know this sounds weird, but check your yellow wire. Most head units just keep time etc on the yellow wire and do almost everything else from the switched red wire, but head units will act like this if the yellow or red is broken, shorted, or a fuse is blown. Make sure to check your fuses. It doesn't take much to pop one when installing a new head unit. If you want to test, just find any 12v source and hook it up to both yellow and red and give black ground. If the unit does not function properly THEN.... you have a bad unit. If it does, the unit is fine but your wires supplying the power to the unit are bad.

skylineTT
05-26-2010, 02:15 AM
yeah i have it on a 12v power supply with both red and yellow on the power and black on grnd. still doin it/

raverx3m
05-26-2010, 06:58 PM
kenwoods had issues with display backlight.
the onboard resistors would get desoldered and display stops working.
i fixed about 4-5 of them by resoldering every onboard resistor i could find and it worked

skylineTT
06-05-2010, 08:32 PM
hmm okay and thats on the main board? i need to fix this badly