PDA

View Full Version : Still having problems with the rainbows



Terranova
03-19-2010, 08:36 PM
I bought the slc265.25 ng's about a month or so ago and from day 1 I had problems with the front right tweeter always cutting out and the left one staying loud and strong through everything. Well last weekend I finally decided to yank the bulb out and put a jumper wire on the right sides crossover so it would stop. Well guess what? IT STILL ****ING DOES IT! WTF? I want to sell these tweeters and actually get a good set of tweets. How much can I sell these for anyways? $260 set of top quality speakers that can't even get remotely loud without crying bi*ch. Here is the link to the first thread. http://www.caraudio.com/forum/speakers/463816-rainbow-slc-265-25-ng-need-some-help.html

Johnny Law.Lulz
03-19-2010, 08:55 PM
So you want to sell a fucked up pair of tweeters ?

Terranova
03-19-2010, 09:00 PM
So you want to sell a fucked up pair of tweeters ?

Uhhh no.. It was a test I did for 10 minutes tops. The tweeters work fine there not blown they haven't been pooped on or anything. The halos are back in the crossover.

Johnny Law.Lulz
03-19-2010, 09:07 PM
I bought the slc265.25 ng's about a month or so ago and from day 1 I had problems with the front right tweeter always cutting out and the left one staying loud and strong through everything. Well last weekend I finally decided to yank the bulb out and put a jumper wire on the right sides crossover so it would stop. Well guess what? IT STILL ****ING DOES IT! WTF? I want to sell these tweeters and actually get a good set of tweets. How much can I sell these for anyways? $260 set of top quality speakers that can't even get remotely loud without crying bi*ch. Here is the link to the first thread. http://www.caraudio.com/forum/speakers/463816-rainbow-slc-265-25-ng-need-some-help.html

Seems that way to me, if you are going to play the i didnt test them that long card, then why not see if you can even fix the problem first.

Terranova
03-19-2010, 09:22 PM
Seems that way to me, if you are going to play the i didnt test them that long card, then why not see if you can even fix the problem first.

Ok so I guess swapping the crossovers running new wire soddering the wires turning the tweets down at the crossover and turning the treble down and even trying to get the settings perfect with imprint doesn't count then I'm screwed. And rather then being a douche bag why not give some input on what I can do to fix this problem huh?