PDA

View Full Version : Distortion coming from speakers, help!



jonB
01-01-2004, 09:54 PM
I am runing an avonixx 440.4 amp to my front cdt classic comps and my rear bostoin Acoustic coaxials. I am getting slight distortion from all speakers and adjusting the CENS only helped minimally. My question is would adding an external xover help clean the signal up a bit or would not make any difference whatsoever? I have this audiobahn xover and was wondering if there'd be any point adding it. Also if i do so will the xover on my alpine 9807 deck still be functional?

Redford
01-01-2004, 11:16 PM
the cross over could help if your speakers are trying to play too low... try turning down the bass on your HU and see if that helps... if it does I think thats a sign to add the crossover.

jonB
01-01-2004, 11:41 PM
the cross over could help if your speakers are trying to play too low... try turning down the bass on your HU and see if that helps... if it does I think thats a sign to add the crossover.


Nope...it's more of a static sound it's very very slight you can hear it usually in the begning of songs or more quiet moments during the sound, it's not bass related

helotaxi
01-02-2004, 06:51 PM
Sounds like more of a noise problem than a distortion problem. Adding another component won't make it go away and may make finding the source even more difficult. Check all of your component grounds. If the noise just started, it is likely that one of your grounds has worked its way loose. Also check to make sure that your RCAs are plugged all the way in. They can work loose over time and the loose connection can introduce some noise.