PDA

View Full Version : Component Help.. Speaker is making wierd noise



Kross6622
11-17-2009, 07:35 PM
Okay so i bought a pair of MB Quart Premium 216's...

these where the ones made in germanys etc...

My doors are a major pain in the *** to work with and so long story short i was only able to get the driver door off about 3 weeks ago... installed the woofer tweeter crossover etc... turned it on worked fine... no issues.

Today i was able to get my passanger door off finally and installed that speaker, everything went good...

I went to tune them up and i notice my driver door woofer making this terrible sound when turned up.

I took the panel off and everything looks fine, the surround is fine, the cone is not rip or tore and it sounds good up until a certain volume.

I have been usiong this speaker for 3 weeks+ and didnt adjust the tuning from the first time and it is set to only get ~65 watts rms and thats unclipped (running a rockford t 400-4 bridged ~250 watts rms each speaker) and no issues..


So its pitch black outside and no way for me to get light etc... What do you think it could be... What would it sound like if its hitting the tinsel lead?


The sound is a fast buzz sound like if it was hitting something.

I plan on taking it out tmw and looking at it.

SPLluminator
11-17-2009, 07:36 PM
Probably vibration from your door panels. I have this horribly. Idk what the best way to stop it is. Well obviously sound deadening but idk what else.

Kross6622
11-17-2009, 07:42 PM
i got sound deading... it was working perfectly fine 2 hours ago and i didnt even touch that door.. its only coming from the woofer... did it blow? but wouldnt the cone/sorround have a tear or rip... i mean on low volume it sounds fine..

Kross6622
11-18-2009, 05:30 PM
bump... about to go outside and take the door panel off and take the speaker out.

Kross6622
11-18-2009, 06:03 PM
ok took the speaker out and it was making the noise so it doesnt have to do anything with the door... i check the amp and thats fine so power is not an issue... completely unhook the speaker and took it inside for a good look. No tears rips, burns etc... looks perfectly fine.

what could cause this noise... its not hitting the leads or anything... could a piece of metal got into the whole? would that cause this to happen? i need some suggestions...

Kross6622
11-19-2009, 07:40 PM
bump