PDA

View Full Version : My Battery Wont Stay Charged



Donks
09-10-2009, 08:43 PM
I have a 1972 cadillac. its got a new alternator and new battery. It did work fine 4, then 1 day it decided to stop staying charged. i checked all the wiring and the alt wiring. it just seemed to stop working a few days ago.....so i have to keep recharging to battery because the alt. isnt doin its job. So my radio cut out today. turned out 2 b the radio fuse in the fusebox....while i was checking the fusebox i seen the B/U slash DEFG fuse was blown. it was a 25 fuse.

Could this b the reason the reason why the alt isnt charging correctly?

my 72 caddy is super oldschool BTW it takes Glass Tube Fuses in the fuse box. Usually a car would have a fuse the would say alt or batt...but there isnt one on my caddy that say's that.

jon_k
09-10-2009, 10:33 PM
If you want to be educated about car charging, go here:

http://www.bcae1.com/charging.htm

Bologna
09-10-2009, 10:53 PM
is there a positive wire going from your alt to your batt pos?

Donks
09-10-2009, 11:38 PM
that did give me a little more knowledge. but i still dont know what MY problem is....hopefully its just that fuse.

Donks
09-10-2009, 11:38 PM
is there a positive wire going from your alt to your batt pos?

Yes. Sir ........i dont think it could be the wiring cause it was working fine a few days ago...then its just stoped charging. I can jumpstart it everytime though with no problem. BTW i did have my gell cell battery hooked up in the back for the system.
Yes i disconnected it....but then again i remember everything was working fine a few days ago. even the gell cell in the back.

It has 2 b something simple im just not noticing. Hopefully its this B/U slash DEFG fuse. idk.....its stressin me out

phemps
09-10-2009, 11:42 PM
do a load test on your battery to rule that out. then drive down to the local autozone and get a free charging system test

Donks
09-10-2009, 11:51 PM
Yea if i had MY **** DMM READER everything would be flowing a lot easier....but my dog got to it before i could.....**** DOG.

how do i perform a load test? Also i will be going to the AutoZone in the moring to get those fuses. so i'll have them check everything.

phemps
09-10-2009, 11:54 PM
youd need a battery load tester. but it sounds more of an alt charging issue, if your battery isnt charging. altho when my battery took a shhit it wouldnt hold a full charge it would take like 9 volts then lose it fast if i let my car sit. either way the charging system test will give you the info you need tofigure out the problem

Donks
09-11-2009, 12:44 AM
yea i'll let u know in the morning what happens

Donks
09-11-2009, 01:15 PM
I just came from the AutoZone. They tested it and the battery is good. The man said by the way it sounds Problem was the starter was bad. But I Just pulled the starter off and took it 2 the store and it Tested good. So WTf Is the problem now?

To me it sounds like there it is a starter shim problem or flywheel problem somewhere because the battery is a RedTop Optima and i charged it overnight and now its charged and it still reads 12v +

BTW my car only starts in Neutral.....meaning the nuetral safety switch may need replaced but that shouldnt have anything to do with why it wont stay charged once its started.

Donks
09-11-2009, 05:08 PM
ok i think i've nailed it down.....its got 2 do with something between the starter & flywheel.

Donks
09-22-2009, 10:49 AM
nevermnd it was the started needed shims and the Alt. needed a new voltage regulator