PDA

View Full Version : Wtf is up with my AC?



Lonnie
09-09-2009, 07:21 PM
OK

I own a 1990 Cadillac Sedan Deville. The diagnostic codes show F47 which is low freon. BUT the gauge is showing full freon. Made me waste $25 for a can of freon with the gauge. If the compressor is screwed up would it be showing low freon?

Yea I know dont need AC but I cant stand when something is messed up on something I own. The car is already running like crap due to eathier it not giving the engine enough gas or a plug is bad. Only 2 things I can come up with. I guess if you can come up with something different I will say whats wrong with it. Right now it idles a little rough and it vibrates when accelerating. It usually does it when its in 3rd gear (highest). But as of yesterday it started doing it in 1st or 2nd. It will sometimes go back to doing it on 3rd and run fine in first and 2nd...sometimes it does it in all 3. Earlier it was doing it up a hill...so I pushed in the gas pedal to the floor...but it acted like I didnt and still slowly went up the hill. SOOO yea if you can come up with something different than go for it lol. If it is the plugs im hoping its one of the front 4 and not the 4 near the fire wall...**** FWD cars aye?

Well also the passenger window is off track and the door lock doesnt work...but its just $30-$60 to get that fixed. WILL get it fixed before I get my system hooked up though...just dont like the idea of having the doors unlocked. Plus if I fix the lock the Alarm system might start working. Purchased the car maybe 2 months ago.

audioatg
09-09-2009, 09:09 PM
One what gauge is showing that the ac is full. Secound. Have you check the plug wires(good spark) use a spark tester go to each one. Spark plugs(see if they are gaped right) Mummm 1990 still might have a coil pack. Check that or the distributor cap and rotor.

infamous_e46
09-09-2009, 09:12 PM
Expansion valve bad on a/c or the cycling switch ?

oldschoolboomer
09-09-2009, 09:21 PM
johnson spring in compressor is worn out.

quins90lac
09-09-2009, 11:17 PM
go here they will set you in the right direction http://www.cadillacforums.com/forums/ and yes you do knead the ac the ac kicks on even when you have the heater on to help git rid of condensation on the heater core

1lowZ56tahoe
09-15-2009, 11:06 PM
(note to others looking at this,these tips are for the front wheel drive cads they are the ones with this type of ac setup only)reset the ac control by removing the battery cable for 1 min then reinstall,crank,cut ac on and then check freon level because when the code sets the compresor will not cycle until its reset.the miss sounds like a dead plug wire or fouled plug,dead wires are common in the older cads due to high under hood heat. ASE cert tech for 19yrs

FloridaStanza
09-16-2009, 08:49 AM
The symptoms your refering to with the vibration and loss of power may be a transmission problem, my dad used to have a 91 and it had similer issues when the tranny stopped going into first wich throws the whole computer into loop mode. Check and see if your getting worse gas milage than before.

Lonnie
09-17-2009, 10:10 AM
Figured out what all was wrong with it if im not mistaking. Was giving an Air flow control code...tightened some hoses and reset the codes...it isnt coming back. One code is though...ISC RPM Out of Range. Might have something to do with the plugs...going to get a tune up this Tuesday. The AC might have something to do with the cheap antifreeze the previous owners put in the car. The car requires a specific type...and was told if its wrong then the AC wont work. BUT then again it could be related to the older type of freon. Its been converted but the directions could still be related with the older type. ALSO the shaking is very likely being caused by one of the transmission mounts. The motor literally jumps when you give it gas lol. Getting the mount Tuesday after I get payed. It probably also needs fuel filter changed since ive been using a crap load of fuel injector cleaner+octane boost...it might be getting a bit clogged depending on what all I managed to clean out of the injectors.

badvlvo
09-17-2009, 06:07 PM
Expansion valve bad on a/c or the cycling switch ?

This could be an issue. Or there could be a restriction in the line. A clogged orifice tube comes to mind. Pressure will read OK on one side, the other will be low or normal until the demand exceeds the flow.



Figured out what all was wrong with it if im not mistaking. Was giving an Air flow control code...tightened some hoses and reset the codes...it isnt coming back. One code is though...ISC RPM Out of Range. Might have something to do with the plugs...going to get a tune up this Tuesday. The AC might have something to do with the cheap antifreeze the previous owners put in the car. The car requires a specific type...and was told if its wrong then the AC wont work. BUT then again it could be related to the older type of freon. Its been converted but the directions could still be related with the older type. ALSO the shaking is very likely being caused by one of the transmission mounts. The motor literally jumps when you give it gas lol. Getting the mount Tuesday after I get payed. It probably also needs fuel filter changed since ive been using a crap load of fuel injector cleaner+octane boost...it might be getting a bit clogged depending on what all I managed to clean out of the injectors.


AC has NOTHING to do with cheap antifreeze. Different system entirely! Stop listening to that person immediately or you will **** something up on your car!

Your fuel filter may need to be changed but it is not dependent on how much garbage came out of the injectors.

Fix the tranny mount.

Pull the IAC and check for function and carbon buildup. If it's stuck open it will cause a idle issues and other driveability problems seen at less than 1/4 throttle.

Look on the forums and find the proper diagnostic procedures. You are wasting money with fuel additives and replacing unnecessary parts.