PDA

View Full Version : CDT ES Comps problem



subydude81
08-18-2009, 11:19 PM
Gave my brother my old car 06' impreza and it has the newer CDT ES 6.5 comps. I had an amp running them when I drove the car but it no longer has an amp, only a kenwood excelon deck powering them. Seems the tweeters play fine but the midbass speakers have like no sound other then high frequencies. I switched the deck out to make sure it wasn't that and I ruled out the deck being the problem. I have to take the door panel off to look at the crossover just seems weird both mids are not playing correctly. Possible both crossovers are blown??

Side Show
08-18-2009, 11:26 PM
check your highpass filter settings......

Abarca
08-19-2009, 02:12 PM
put an amp on them, u cant expect much from runnin off the HU. give them 150-200rms and they will shine

subydude81
08-19-2009, 02:41 PM
check your highpass filter settings......
made sure I checked that on the kenwood deck and thats ok


put an amp on them, u cant expect much from runnin off the HU. give them 150-200rms and they will shine
Oh I know I cannot expect much but this is not like its not getting enough power, there is nothing but high frequencies coming out of the mid.

kizz
08-19-2009, 02:51 PM
kind of a stupid idea but ur speaker wires aren't switched around on the crossover are they? mid to highs and vise versa?

subydude81
08-19-2009, 05:05 PM
kind of a stupid idea but ur speaker wires aren't switched around on the crossover are they? mid to highs and vise versa?

Nope, I haven't touched anything behinds the door panels yet. I had them running off a 5 channel only a few months ago and worked fine, now theres got to be something either with the crossover or the mids.

KOL
08-19-2009, 05:45 PM
Oh I know I cannot expect much but this is not like its not getting enough power, there is nothing but high frequencies coming out of the mid.
The lower midbass frequencies need cone movement to be reproduced with any kind of usable output. You need power to get that speaker moving.

Shouse94
08-20-2009, 01:56 AM
^ X2!