PDA

View Full Version : p860mp faceplate problem(yes, i searched)



BLD 25
08-01-2009, 01:05 AM
the face opens halfway and then tries to close and can't. when i turn the car off, it closes just fine. I searched and found a thread where someone said to spray wd-40 in there and it worked again. That didn't work for me. the ribbon cable looks good from what i can tell, but any other thing i should look for? Where is the best place to buy a ribbon cable?

thanks

BLD 25
08-01-2009, 11:32 PM
lil help?

FOSGATE JOE
08-02-2009, 04:29 PM
mine did the same thing after 2 years of heavy use with the c.d player.what to sale it

BLD 25
08-02-2009, 04:46 PM
mine did the same thing after 2 years of heavy use with the c.d player.what to sale it

What do you mean by "what to sale it?"

grassroots
08-02-2009, 04:53 PM
is this the older dual faceplate one? or the newer one?

if it's the old one you need a new ribbon cable plain and simple. i've had both the 860mp and the new 960mp and they both had ribbon cable problems. they had do it yourself kits on ebay for 50 bucks.

FOSGATE JOE
08-02-2009, 06:04 PM
What do you mean by "what to sale it?"lol on me:p:..Do you want to sell it :greedy:

BLD 25
08-02-2009, 06:53 PM
I might want to sell it. I ordered a ribbon cable and I might see if i can fix it.

CrispedUp
08-02-2009, 06:55 PM
lol on me:p:..Do you want to sell it :greedy:

fixed

FOSGATE JOE
08-02-2009, 10:16 PM
fixed;) thanks

ejschultz
08-02-2009, 10:24 PM
I know it's a little late because you already ordered the ribbon cable, but for future reference, pacparts.com has a bunch of replacement parts for all sorts of head units and head unit accessories.

BLD 25
08-03-2009, 06:43 PM
didn't work out too well:
http://i9.photobucket.com/albums/a83/Bdavis16/001-1.jpg