PDA

View Full Version : speakers making a clicking sound...



gnatnoop
07-20-2009, 10:30 PM
i just installed a new component set a couple weeks ago, they are the ID ctx65cs.. when ever i open the door, the glove box or change a song they make this very annoying and very loud clicking noise (both mids and tweets make the noise..) both sides do it, but rarely at the same time.. for example i will open the glove box and only the passenger side mid and tweet will make the noise, and its ****ing annoying the **** out of me.. any help would be appreciated..

gnatnoop
07-20-2009, 11:07 PM
anyone?

okiedokie
07-21-2009, 12:49 AM
have you checked your ground?
if i where you i would check everything
1)start with head unit wiring
2) check the wire in your doors, you could of clipped a wire
3) check the amps
4) you could have a short with those passive xovers.

gnatnoop
07-21-2009, 02:39 AM
have you checked your ground?
if i where you i would check everything
1)start with head unit wiring
2) check the wire in your doors, you could of clipped a wire
3) check the amps
4) you could have a short with those passive xovers.

checked my ground, it is a awesome ground...
the speakers r not wired to headunit but i will check the headunit ground tommorrow, possibly make another one just to be sure/ have 2
checked wire in doors, they are perfect... checked the amp, all wires secured and perfect..
checked passives everything seemed to look fine..

gnatnoop
07-26-2009, 07:13 PM
it was a hu ground.. go figure

okiedokie
07-27-2009, 03:53 PM
yep, happy you fixed it