PDA

View Full Version : Alpine iDA-X305 "USB Device Error"



FriendlessNerd
05-15-2009, 01:08 PM
I Googled and there are only a few dozen hits on this specific error.

I have an X305 using the USB cables supplied by Alpine. I've tried connecting a 5th Gen iPod and an iPhone 3G. Neither one works. I've reset the hu, reset the iPod, reset the iPhone, unplugged and plugged while off, unplugged and plugged while on, unplugged and plugged in AM/FM, unplugged and plugged in USB and nada. When the iPod is plugged in, I get "USB Device Error." When the iPhone is plugged in it's either "USB Device Error" or "No USB Device."

I know something is working because my iPod charges.

The iPod and iPhone have the firmware versions suggested by Alpine.

One site suggested enabling disk usage on the iPod as a fix...but my iPod already has disk usage enabled.

I'm thinking it's possible that it's 1) a bad cable, 2) a bad USB input at the hu, or 3) just a defective hu, because some obviously have this problem and some don't. I'm going to head back to the installer today because it's faster (and will probably yield better results) than calling Alpine tech support. In the meantime, anyone have any ideas?

sdsurfer
05-16-2009, 07:36 AM
I have an iDA-X100 ,that happened to me few times ,but I was able to fixed it with reseting my iPod though.

AlterEgo99
05-18-2009, 09:53 AM
Just curious, did you get this fixed?

FriendlessNerd
06-08-2009, 06:39 PM
Sorry. Forgot to update. The original USB cable was defective.

Slinky
09-28-2009, 10:00 AM
Hey guys i was doing a search and found this thread so i'm kind of digging it up for my frist thread.

I just installed an x305 in my truck and i'm having the same problem with the USB Device Error...how did you determine it was the cable?
I'm using a 5th gen ipod Video 30g with 1.3 software

i also tried plugging in a sandisk (i think thats what its called) mp3 player to see if it would recognize that and all that does is make the deck want to shut off.

I hope its an easy fix like the cable.

thanks

Paperm4ker
11-12-2009, 06:24 PM
Hey i know this is an old thread but I just wanted to help anyone others that were having the same problems as me. Apparently I wore out the IDA-x305 ipod cable because it kept connecting and disconnecting to the point of uselessness but would still connect to my USB drive :mad: It's a mystery...

I found that you can buy another replacement USB cable from alpine's part store http://www.pacparts.com and searching the model. Me being impatient and wanting to fix it immediately instead of waiting for it to ship, I searched some electronics stores to see if they had a similar Alpine cable and found that the Alpine KCU-440i cable which says that it's only for the CDA-105 series head unit actually IS the original cable for the IDA-x305 according to Alpine's Australian website... It also has the USB to Ipod interface cable so you are able to listen directly from a USB drive and connects and powers my Iphone 3g running 3.1.2 firmware.

The link to the Alpine website for the KCU440i cable is here (http://www.alpine-usa.com/US-en/products/product_acc.php?model=KCU-440i). I don't know why Alpine would leave that info out of the manual AND USA website and then specify it ONLY on the australian website here (http://www.alpine.com.au/products/product.asp?modelID=408&search=1)... thanks for making that piece of imformation extremely difficult to find :wow:....

The ONLY difference I can see in the original cable and the KCU-440i is that the original cable has a screw attached to the USB to attach to fasten it to the back of the head uint, which isn't completly necessary in my case, but so far the cable has been working flawlessly as a replacement. I found that some Best Buys carry the cable but i would call first to check.