PDA

View Full Version : Scammed by dipitydoo!



scotthulbs
03-28-2009, 01:00 PM
I bought an MTX amp from this guy a while back. It worked fine for the a few months. Then about a week ago it stops working. So today I get time to finally remedy the problem. After trying everything I open the amp to find 2 missing mosfets. Not Burnt from my use but they were completely gone the aluminum bar to secure them in place was missing and the board was charred where they used to be. Now its been too long for me to take any action other than this. On the plus side I learned to completely take apart anything I buy online to check for this kind of ****.

Thanks dipitydoo, hopefully Karma is a *****.

Luckily for you, you live so far away otherwise we would have a face to face :mad:

BushJ311
03-28-2009, 01:32 PM
Pics?

dipitydoo
03-28-2009, 02:21 PM
ummm, as explained in my reply to you, the amp worked fine when i bought it from another ca user. i never opened the case. i have no knowledge of the missing mosfets. unfortunately, i cannot warranty any products 6 months after purchase. i wish i would have known about this problem immediately after purchase.

05fronty
03-28-2009, 02:26 PM
shouldn't have worked in the first place if it was missing components off the board?

infamous_e46
03-28-2009, 02:29 PM
http://gispro.files.wordpress.com/2007/06/bullshit.jpg

SlowCamaro
03-28-2009, 02:33 PM
interesting

bigbangtheory
03-29-2009, 09:28 AM
I am with smllysack on this one. Sounds to me like the amp went kapoof and the buyer is trying to put this on the former seller.

Kind of a hard one to tell who is BSing who.

Louisiana_CRX
03-29-2009, 09:44 AM
pretty weird for it to work several months without noticing any problems......

basebalz13
03-29-2009, 10:12 PM
yeah i agree with louisiana on this one, def weird