PDA

View Full Version : High & Mid-basses filtered out



deminn
03-19-2009, 04:10 PM
Okay, so I just got my 2 MTX T9512 Subs and 1 MTX 1501D Amp installed and it is thumping like crazy. But I noticed that my front and rear speakers are lacking power in the high and mid-range basses. In fact, sometimes I can't even hear the high and mid-basses at all. It's not a full sound. In a song that I'm listening to, the very low basses would kick in through my subs but as it goes up, the high and mid-basses fade out and it sounds horrible. Before I got my amp and subs installed, my stock speakers in my car played all the high and mid-range basses very clearly.

I did some research on crossovers and it seems that this might help the problem, but where do I start? My car is a 2005 Mazda6 and it has a bose system that sounds pretty nice already before the subs/amp was installed. Would you guys suggest upgrading all four front/rear speakers? Would that solve the problem without a crossover? Is an equalizer necessary? What is the difference between a mid-bass speaker and a mid-range speaker? Would I need to get another amp to power those speakers? I only have a mono amp right now. Money is not an issue for me as long as none of these exceed over $1000. Some of these questions are kind of dumb but I hope you all don't mind answering them. I do want opinions too. I am still a newbie in the process of learning all this stuff. So thanks in advance!

djman37
03-19-2009, 04:24 PM
Who did the install? You just can't tap the wires in some systems(i.e. bose) and expect it to work.