PDA

View Full Version : Hertz MLK165



wasted911
03-14-2009, 08:08 PM
Well I thoguht I'd let you guys all know about this, as I'd hate to see it happen to anyone else, and to find out if it's happened to anyone else.

I bought a set of Hertz MLK165 components about a year ago, and withing 2 weeks I heard the most aweful noise. I notice that the surround had torn on the driver side mid. I was PISSED. I brought the speaker back, and they got a replacement in (took about 3 weeks). About 2 weeks later, I got the same noise. This time both mids had the surrounds torn. I was suggested to turn the crossovers up (was at 40 hertz, then turned them up to 60). Once again, they wrecked.

This time the Hertz rep took a look at the install, and figured it was moisture getting in the door and freezing. I figured he was probably right.

From here on I kept the volume down until the surrounds warmed up. Once more they went (I turned it up too early). I put in one of my hi-energy mids that I have lying around and used it as a temp.

The hi-energy was perfectly fine in -45. I've come to the conclusion that these speakers really shouldn't be used in any application that it is cold. I would like to warn every one of this before purchasing these speakers.

Before everyone says that it's install related a friend of mine had the same thing happen to his.

Megalomaniac
03-14-2009, 08:11 PM
the milles are made from a different pressed paper than the high energies.


Thats pretty funny complaining about your speakers breaking in -45 :D id be complaining about the weather more :p:

Toone
03-14-2009, 08:15 PM
I dont think they take weather that far into consideration :fyi:

wasted911
03-14-2009, 08:17 PM
The surrounds start to harden up at around -5 Celcius

michaellane
03-14-2009, 08:17 PM
made me laugh...sorry to hear that tho

t-money
03-14-2009, 09:02 PM
i live in toronto canada and it gets **** cold out here. I've never had a problem at all with my mlk 165's and i play them loud in the cold. I have my doors deadened and i have 400 watts going to them.

lrc131
03-17-2009, 08:38 AM
i also had this problem, i made a thread here with pictures a while ago... it wasnt pretty lol. my dealer stopped selling the milles for this reason.