PDA

View Full Version : Infinity 6x9's Distorting



mrmafioso04
08-15-2003, 12:39 AM
I installed my infinity kappa 693.5i 6x9's speakers in a buick century 1990. I put a 100x2 at 4 ohms amp to the speakers their RMS power is 110. When i turn the volume up on my speakers they get loud distorted bass. It rumbles a lot and sounds hella ugly. I can barely turn it up halfway without it distorting cuz the bass hit hard and rumbly sounds like farts ahaha. Nah its not that bad but i know it should be a lot clearer. Do you think i need some boxes for these speakers? I have a little rug on the rear deck over the speakers and i think the rug is half of the ****ing noise. I dunno tho it sorta sounds like the speakers are distorted anyway. plz help. The amp is a profile amp so not horrible but not hella good.

Gauntlet
08-15-2003, 05:08 PM
RMS is 110....but in reality you shouldn't send them more than 80. Oval speakers distort badly when pushed to full excursion....your most feasible option is to either get new speakers or a new amp.

M-Town
08-15-2003, 06:32 PM
i had the same problem, i used my HU amp which was like 27rms...it had really crappy bass...barely sounded like bass at all really. the highs sounded good tough. im not sure what the problem is...100 rms does seem to be to much though, try turning the gain down a bit.

Bavarian3
08-15-2003, 07:22 PM
try turning down ur gain, make sure the bass boost isnt turned up at all, make sure ur crossover is set properly.

mrmafioso04
08-16-2003, 03:03 PM
i turned the bass boost down and adjusted the gain and started ****ing with the crossover till the speakers stopped distorting! They sound good as hell now crystal clear!

lexiphanic
08-24-2003, 09:44 PM
Same here. I did the same thing that you did, set the crossover until you stop hearing them distort.

I'm going to try installing them in boxes to see if it cuts down on the bass distortion. We will see if that helps.