PDA

View Full Version : Finally fixed my Alpine 7909 pics and video !



Rob.
01-27-2009, 06:59 PM
Hey, good news ! The power supply was gone on this 7909 unit, so I had the unit repaired by Chris at S&S electronics here in Toronto (www.s-selectronics.com/978/index.html). Highly hghly recommended repair shop ! WC Enterprises in Markham http://www.wcent.ca/ (Canadian Alpine authorized repair shop) said it was not repairable due to part being NLA...haha !

Sounds amazing ! I Havent heard anything this clean in car audio ever !!
Even the installer was impressed , and hes been doing car audio for 20+ years...

Here's some pics and a video !

Raw unedited video:
http://ca.youtube.com/watch?v=OzFAtTqBg1s

http://i107.photobucket.com/albums/m305/rob89m3/Alpine%207909/DSC00291.jpg
http://i107.photobucket.com/albums/m305/rob89m3/Alpine%207909/DSC00290.jpg
http://i107.photobucket.com/albums/m305/rob89m3/Alpine%207909/DSC00286.jpg

Louisiana_CRX
01-27-2009, 07:04 PM
looks good...i'm glad you got it going....

Bass Addict
01-27-2009, 08:07 PM
how long did it last before you had it repaired.im curious at the life expectancy of an alpine

jmanpc
01-27-2009, 08:08 PM
clean unit! glad its workin.

ThatChevyGuy
01-27-2009, 08:10 PM
cool that looks old

Rob.
01-27-2009, 08:10 PM
how long did it last before you had it repaired.im curious at the life expectancy of an alpine

The unit itself is from 1989. I bought it in disrepair for cheap from someone recently.They hadnt used it since 2003.
I had it repaired now, this is the 1st time I have hooked it up since I got it, so I dont know how long it lasts.

Bass Addict
01-27-2009, 08:13 PM
The unit itself is from 1989. I bought it in disrepair for cheap from someone recently.They hadnt used it since 2003.
I had it repaired now, this is the 1st time I have hooked it up since I got it, so I dont know how long it lasts.wow,1989 lol.thats good to know,glad you got ur's workin bro.at least now i know i'll be able to use my two alpines for years to come.thanks for the info,much appreciated :)

Rob.
01-28-2009, 01:53 AM
np problem

93LuminaZ34
01-28-2009, 04:56 AM
7909 was a premier HU to use in sound comps back in the day. They sound so good. and they looked good to. good to see one ressurrected. Last time I saw one for sale on ebay it went for 400.00

93LuminaZ34
01-28-2009, 04:59 AM
ok that was cool Journey as your demo music. Pretty good front stage even on a a video.

nikhcePtcejorP
01-28-2009, 05:00 AM
7909 was a premier HU to use in sound comps back in the day. They sound so good. and they looked good to. good to see one ressurrected. Last time I saw one for sale on ebay it went for 400.00

I'm sure it is nice and was the ish back then, but i just don't see myself buying a headunit from 1989 for 4 bills

Go2Sleep
01-28-2009, 05:06 AM
nice.

Rob.
01-28-2009, 12:43 PM
7909 was a premier HU to use in sound comps back in the day. They sound so good. and they looked good to. good to see one ressurrected. Last time I saw one for sale on ebay it went for 400.00


they go for more than that, unless its in bad condition.

Rob.
01-29-2009, 08:20 PM
I'm sure it is nice and was the ish back then, but i just don't see myself buying a headunit from 1989 for 4 bills

I You want the best rare old skool, you gotta pay. :crazy:

t-money
01-30-2009, 12:01 PM
wow,1989 lol.thats good to know,glad you got ur's workin bro.at least now i know i'll be able to use my two alpines for years to come.thanks for the info,much appreciated :)

i've had my 9835 for 5 years now, with 0 problems ***runs to knock on wood***

Rob.
01-30-2009, 09:24 PM
i've had my 9835 for 5 years now, with 0 problems ***runs to knock on wood***

Thats a nice deck and all.... but Im not a fan of newer alpine headunits...I think they are made in china now and use very cheap internal parts..
I prefer the old school.

Rob.
02-02-2009, 07:58 PM
Uploaded a couple more vids:

YouTube - Alpine 7909 cd video 3 (http://ca.youtube.com/watch?v=nZx4bqsw6FM&feature=channel_page)

YouTube - Alpine 7909 cd video 2 (http://ca.youtube.com/watch?v=zNGNip4cTRU&feature=channel_page)