PDA

View Full Version : RSD's after 6 weeks



joshs98runner
01-22-2009, 03:52 AM
So I finally got around to putting in my PG RSD6.5's about 6-8 weeks ago and put them on my 75x2 amp and have been very happy with the set. I absolutely love the mid-bass that comes through the set (the doors have 2 layers of raamat). I have been playing them pretty loud for the better half of their life so far and to my surprise am disappointed to find one of the tweeters starting to distort at higher volumes already. I was wandering if anyone else has had any trouble with this tweeter set? I have been pretty careful to keep them under a level that they would distort on...my PRS-960mp head unit has a volume scale from 0-40 and I don't typically play them over 27-32 on any songs. The majority of their playing has been on the 16-22 volume level which is not really ear piercing. I have not noticed any clipping from them at any volume level i have touched and figured my amp has enough head room to play them loud pretty safely. Do you usually have to be pretty conservative on loudness with cloth dome tweets? This is my first set of components so I was kind of expecting more longevity from them.

P.S.
Not sure if it matters too much but the amp has 4 gauge wire going to it and the speakers have 14 gauge from the amp terminals to the crossover and from the crossover to the speakers so I didn't really skimp on any install parts...

mlstrass
01-22-2009, 09:42 AM
Gain too high on amp? Tweeter level too high on HU? Several people on here have had issues with tweeters going out and they all seemed to buy from the same place. There's a thread on it if you search...

XHiFiX
01-22-2009, 10:09 AM
The same people who bought them from audiosavings are usually the same ones who report problems with their tweeters....BUT I think it's just coincidental and not an issue of the the merchant.

I bought my set from them and never had a problem with my tweets. They've seen HU power, 50WRMS from a small Pioneer amp, then 130WRMS from an Eclipse PA4212. With electronics you just never know if or when something will go bad.

Have you confirmed it's really the tweeter? It might be the crossover. Try wiring it to the other one and see if it still has problems. Also try the +2/0dB dipswitch for the tweeter output.

joshs98runner
01-22-2009, 11:20 AM
Thats a good idea. I'll try moving the dip switch to +2. If that doesn't change it I will try swapping crossovers. If all that doesn't do anything then I will probably be giving PG a call to see if they can help me out with some new tweets...

Just a thought...If the PG tweets do go bad on me would it be an easy task to find some other tweeters that will sound good with the mid driver and crossover set I already have? I hear good things about the Cal25 tweets as well as other stuff but I don't know if I want to make the investment on a set of tweets if it will just throw the rest of the system off...

joshs98runner
01-22-2009, 11:25 AM
hmmm... http://cgi.ebay.com/RAINBOW-SLX-265-DELUXE-6-5-New-2-Way-Component-System_W0QQitemZ120361383478QQcmdZViewItemQQptZCar _Speakers?hash=item120361383478&_trksid=p3286.c0.m14&_trkparms=72%3A1234|66%3A2|65%3A12|39%3A1|240%3A13 18|301%3A1|293%3A1|294%3A50

boomzilla
01-22-2009, 11:25 AM
It might work, some people use different mids and tweets, and a homebuilt crossover. It depends though, some mids and tweets work well, some don't.

joshs98runner
01-22-2009, 11:26 AM
http://cgi.ebay.com/RAINBOW-SLX-265-DELUXE-6-5-New-2-Way-Component-System_W0QQitemZ120361383478QQcmdZViewItemQQptZCar _Speakers?hash=item120361383478&_trksid=p3286.c0.m14&_trkparms=72%3A1234|66%3A2|65%3A12|39%3A1|240%3A13 18|301%3A1|293%3A1|294%3A50 (http://cgi.ebay.com/RAINBOW-SLX-265-DELUXE-6-5-New-2-Way-Component-System_W0QQitemZ120361383478QQcmdZViewItemQQptZCar _Speakers?hash=item120361383478&_trksid=p3286.c0.m14&_trkparms=72%3A1234|66%3A2|65%3A12|39%3A1|240%3A13 18|301%3A1|293%3A1|294%3A50)

oops, try this

joshs98runner
01-23-2009, 05:51 PM
Well I think I am done tinkering with this set. I switched the crossovers to +2db and moved my EQ settings around a bit and that seemed to help but I think I have just exhausted the $80 these things are worth. They started out very smooth, midbass got better for about a week, played clean and loud for a few more weeks and have since been going down hill. My review on this set is they are obviously not the same kind of quality you are going to get from a more expensive set of speakers but they perform very well for their price point. They still play pretty loud but have lost some of their clarity in all areas of output and midbass seems to be getting a little weaker at this point. I will keep them until I can afford a better quality component set and an amp that does 150-180 per side vs. 75.