PDA

View Full Version : Not so happy with CDT ES52i gold



actionhenk
10-27-2008, 01:29 PM
Hola,

I'd like to say that im a total idiot with audio systems so bare with me pls :(
I have a problem with my pair of CDT ES52i Gold (13cm)(dont even know if it can be fixed).

I've bought a pair of CDT ES52i Gold's but im not happy with them. The specs say the speakers can handle 180w rms...theres no way this can be true .

The speakers start to "deform" (by deforming I mean it starts to sound like theres too much amp going to the speakers the speakers start "flopping" and cracking) my music at volume level 15 (I have an Alpine 9884R head unit). The speakers are connected to a genesis profile 4 ultra wich is 4x100 watts...

Do I need a better amplifier for the speakers ? Why is the sound deforming so easily with these speakers ?

Besides this, they definetly lack bass ( im not expecting much bass from a 13cm speaker, but the tweeters seem to push out more bass then the midbass speakers :wow: ).

Thanks!

snoopdan
10-27-2008, 01:33 PM
imo cdt's have always been lacking in midbass output. I absolutely hate mine.

You should probably try an active crossover method for them, like a 30 band eq.

Ridinhi
10-27-2008, 01:33 PM
what do yuo have your xover set on? High pass,low pass,full,etc?

actionhenk
10-27-2008, 01:37 PM
Dont have crossover O_o. I only have an amplifier wich has all the buttons set to off :P

Pressing the high pass filter button on the amplifier doesnt help in the positive way.

Dont know if this is what you mean (like I mentioned, Im a total idiot with sound systems)

Thanks for your replies!

Ridinhi
10-27-2008, 01:40 PM
anyway you can post a picture of how you have the xover wires ran and the amp gains set.

king ranch
10-27-2008, 01:40 PM
u need to have the high pass filter on and set to around 100hz maybe 80hz if they can handle it and depending on how much power u r giving them

also only turn the hu up 75% of full vol, and use a dmm and test tone to set gains so u are close to the power you are wanting to give them

not happy with them 50 shipped i will take them

snoopdan
10-27-2008, 01:42 PM
not happy with them 50 shipped i will take them

lol, 50 would barely cover the shipping on those from where he's at :laugh:

actionhenk
10-27-2008, 01:43 PM
anyway you can post a picture of how you have the xover wires ran and the amp gains set.

Ill post one tomorrow. Its too dark to make a picture of it now.

king ranch
10-27-2008, 01:43 PM
haha didnt see that true very true

actionhenk
10-27-2008, 03:56 PM
Hi,

I have taken some old pictures from the amp, the settings used on it are still the same as Im using now.

The arrows show the direction of the value thats set. I have also marked the setting of the high pass filter button(hope you understand it :P )

Front channel:

http://img143.imageshack.us/img143/7669/amp1ku9.th.jpg (http://img143.imageshack.us/my.php?image=amp1ku9.jpg)http://img143.imageshack.us/images/thpix.gif (http://g.imageshack.us/thpix.php)

Back channel(I guess):

http://img84.imageshack.us/img84/8316/amp2zs3.th.jpg (http://img84.imageshack.us/my.php?image=amp2zs3.jpg)http://img84.imageshack.us/images/thpix.gif (http://g.imageshack.us/thpix.php)

The buttons on the last image dont seem to be doing much...nothing actually ^^ The button on the first image makes it sound even crappier when pushed then without it.

Hope you guys can help me out ;P 700 euros worth of speaker is too much to throw away.

Thanks!

Ridinhi
10-27-2008, 04:05 PM
what model h/u do you have? Did you set the xovers on it?

actionhenk
10-27-2008, 04:12 PM
I have an Alpine cda9884r. Havent set up any crossover on it :S Dont think I have one on my headunit O_o.

Ridinhi
10-27-2008, 04:17 PM
I have an Alpine cda9884r. Havent set up any crossover on it :S Dont think I have one on my headunit O_o.

well,check your bass/treble settings. what are they set on. On your h/u that is.

actionhenk
10-27-2008, 04:24 PM
Ow :P The bass and treble are set to 0 balance and fader as well (0).

exige
10-28-2008, 02:50 AM
PM'ed you. Hopefully we can get it figured out for you. Check that and get back to me when you get a chance.

actionhenk
10-28-2008, 01:10 PM
Thanks for you pm.

PM'ed you back ^^