PDA

View Full Version : buzzing from tweeters



mackin
10-18-2008, 01:38 AM
I can't figure out why my tweeters are buzzing when there are higher frequency bass notes. They only buzz on the higher bass frequencies when the subwoofer is on. If i turn my remote gain all the way down on the sub amp, the buzzing goes away and they are crystal clear.

Any ideas of what could be causing this? I also have a little bit of engine whine so i was wondering if my headunit could also have something to do with this buzzing issue?

System is in sig.

Thanks in advance.

mackin
10-18-2008, 04:20 PM
nobody has any ideas? :(

is there some way my bass is interfering with the tweeter? maybe the grounding issue is causing it?

redcalimp5
10-20-2008, 02:37 PM
nobody has any ideas? :(

is there some way my bass is interfering with the tweeter? maybe the grounding issue is causing it?

Might be a grounding issue, man, or an issue with the tweeter RCA's/RCA connections at your amp/head unit. Not too sure, though, sorry I can't be of more help.

Buck
10-20-2008, 02:52 PM
That's an awfully weird issue.

mackin
10-21-2008, 11:34 PM
Might be a grounding issue, man, or an issue with the tweeter RCA's/RCA connections at your amp/head unit. Not too sure, though, sorry I can't be of more help.
yeah i think i'm gonna try to do the grounding fix on the Pioneer head units and hope that can help

That's an awfully weird issue.
yeah it is lol.

anyone else have any ideas?

skinnymofo
10-21-2008, 11:48 PM
i donno i have a similar issu with only one tweeter making a tick tick tick noise every once in a while. could be the output on the amp or a bad connection.

blazinb2000
10-22-2008, 12:25 AM
Had a tweeter that made a bad buzzing noise and had engine noise, turned out that my rca cable going into the amp was not getting a good connection and that fixed it. that problem bugged me for awhile and had me stumped.

PaulD
10-23-2008, 08:35 PM
Are you sure it's not a physical buzzing rather than an electrical problem ?


skinnymofo ...... try moving your passive xover 6-8"

mackin
10-27-2008, 12:56 AM
Had a tweeter that made a bad buzzing noise and had engine noise, turned out that my rca cable going into the amp was not getting a good connection and that fixed it. that problem bugged me for awhile and had me stumped.
i'm going to have to mess around with these RCA's. thanks.

Are you sure it's not a physical buzzing rather than an electrical problem ?


skinnymofo ...... try moving your passive xover 6-8"

i'm assuming by physical you mean something rattling and it definitely isnt. i tried holding things down and it got louder as i put my ear up to the tweeter.