PDA

View Full Version : My 2000 Ford Explorer



TerryS1980
08-10-2008, 03:16 PM
Here is what I got going on with my Explorer. It's not much of a build log as I am pretty much done with the stereo for the time being. I am new to the site. I usually post on the forums at soundpressure.com.


Panasonic CQ-HX2083 HU
Zapco SX-SL,
Zapco C2K2.5,
Zapco C2K9.0XD W/XD-VFD/WRC,
All Digital Designs Speakers
4 - 5.25" Mid
2 - WS6.5" Midwoofers
6 - DDT 28MM Tweeters
2 - 9515D's
Kinetic 2400
The box is 4.75^3 and 2 6" Aeroports per sub.

http://i40.photobucket.com/albums/e223/TeryS1980/P7260470.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260468.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260456.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260456.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260458.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260464.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260461.jpg

Random1010
08-10-2008, 03:20 PM
how did you paint the dash trim? I have a 2000 explorer too...

Buck
08-10-2008, 03:21 PM
wow great looking

TerryS1980
08-10-2008, 03:21 PM
Here are some pic of the speaker grilles I made for the front doors and covered then in dark red grille cloth. Last pic is the new high end DD tweeters I put in the front doors.
http://i40.photobucket.com/albums/e223/TeryS1980/P7260474.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260472.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260473.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260476.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260477.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/P7260479.jpg

TerryS1980
08-10-2008, 03:24 PM
how did you paint the dash trim? I have a 2000 explorer too...

All of those parts already have factory paint so its just a matter of scuffing up the paint to get it to stick good. I did not do the paint work myself.

bball09124
08-10-2008, 03:24 PM
That is a REALLY nice setup you've got there. Not a fan of that grill or those rims too much, but nice regardless. Have you ever got that setup metered?

TerryS1980
08-10-2008, 03:27 PM
Here are some more pics.
http://i40.photobucket.com/albums/e223/TeryS1980/truck/sidepanama.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/truck/000_8768765.jpg
http://i40.photobucket.com/albums/e223/TeryS1980/truck/newangle.jpg

Random1010
08-10-2008, 03:28 PM
you really like red huh?

18inchjeepin
08-10-2008, 03:40 PM
clean I like it

TerryS1980
08-10-2008, 03:41 PM
That is a REALLY nice setup you've got there. Not a fan of that grill or those rims too much, but nice regardless. Have you ever got that setup metered?
It may have too much chrome for alot of people, but that is how we do it down in South Louisiana. I have not had a chance to meter it yet. I have been offshore working since I finished and there aren't any shows coming up around here anytime soon. The new box should do alot better with the subs up and ports firing back. I posted a 147.6 with my old box that was 5^3 with 100 sq in of port. Here is a pic of the old box, I never completely finished it.
http://i40.photobucket.com/albums/e223/TeryS1980/truck/boxnew.jpg

Louisiana_CRX
08-10-2008, 04:10 PM
looks nice...It makes me hate I got rid of my 99 Ex...:(

crawlinYJ
08-11-2008, 02:00 AM
a little underpowered huh? i run a 9.0 on a pair of 2510's and its perfect.

Louisiana_CRX
08-11-2008, 02:07 AM
That is a REALLY nice setup you've got there. Not a fan of that grill or those rims too much, but nice regardless. Have you ever got that setup metered?

you want things flashey on a show vehicle :fyi:

Skip01
08-11-2008, 09:04 AM
Sweeeet

Where u at in South LA?

I have a Termlab we can mess with too see what ya hit, let me know

TerryS1980
08-13-2008, 03:12 AM
Sweeeet

Where u at in South LA?

I have a Termlab we can mess with too see what ya hit, let me know

I am in Houma. I would definately like to put it on a meter and find my peak freq. I have another friend with 4 15" Power Acoustic MOFO who needs to test his too. He bought a meter off of fe-bay that hooks up to a Fluke meter, but I don't think its too accurate. It is supposed to be within .5db of the TL.


a little underpowered huh? i run a 9.0 on a pair of 2510's and its perfect.

Yes I know I can run a 9.0 on each, but I don't want to make the electrical upgrades to do so. And I will end up buying 2 more 9515's!

The front end of my truck has changed alittle. I put on a paintable bumper and a front air dam, but I did not get it painted yet. I was thinking of painting the whole truck again and going with a silver from the window line up and putting a giant DD in the same red on the hood.

elite08
08-13-2008, 04:21 AM
I like the choice of color!

nice ride!