PDA

View Full Version : Is my HU dead???



LBC99
07-22-2008, 12:34 AM
I'm pretty sure I know the answer. But I just wanted to see if there is something I forgot to check.

I have a Kenwood X890 HU. For the past month or two, every now and then I would turn my car on and notice that my deck reset like as if the power went out. I would have to redo all my settings, which was a pain in the butt.

Today, it reset on me and then a minute or two later, it cut out for good. No power at all is going to it.

When I got home, I checked my wiring, thinking maybe the power or backup wire came loose. They were all fine. I checked fuses, nothing wrong. I checked my battery, good too. My ground was still connected. Is there anything else I might have missed?

I bought this HU on ebay around a year ago, so no warranty. I got it for pretty cheap, so no big deal.

Any help is appreciated, also if anyone has a decent deck for around $50, let me know too.

vitveet
07-22-2008, 01:26 AM
Re check your fuses. Buy a DMM and test power at the ground, 12v and Ignition wires to verify that they have power. If all 3 do have power (when switched on), yeah, the radio's gone. But if I had to guess, I'd say it's an electrical problem from what I'm reading....

V.

LBC99
07-22-2008, 01:49 AM
Re check your fuses. Buy a DMM and test power at the ground, 12v and Ignition wires to verify that they have power. If all 3 do have power (when switched on), yeah, the radio's gone. But if I had to guess, I'd say it's an electrical problem from what I'm reading....

V.

Car electrical or HU electrical problem?

LBC99
07-23-2008, 06:48 PM
So as I turned on my car this afternoon to drive to work, I noticed the red light on my faceless HU blink. My deck came back from the dead!

I put my face on turned on the deck and prayed everything was fine.

Well, that lasted about 5 or 6 six minutes. I tried putting in another CD and right as the CD went in, the deck turned off and now there is no power going to it again.

Any suggestions????? Does anyone know how much this would probably cost to get fixed?

I was thinking of buying another HU, but I really love the features on the x890 and don't really have the money to buy something high-end.