PDA

View Full Version : Excelon X990 ...I cant get DEMO MODE OFF! WTFH!!!



gentlejax
03-09-2008, 05:10 PM
I ran thru all the other menu items and changed what I wanted..no trouble there really...

My trouble is I cant get the Demo mode off and its annoying...I have only had deck installed 30 minutes and still its pissing me off...

I scroll thru till I get to Demo mode and it says ON....no matter how much I toggle the switch or push the control button..

what gives?

edzy
03-09-2008, 05:29 PM
push and hold it for at least 5 seconds.

tEh koRnDog
03-09-2008, 05:31 PM
uh....read the manual?


But seriously...hold it for 5 seconds like the previous post.

/thread.

gentlejax
03-09-2008, 05:36 PM
I did read the manual...the entire manual....


I also held it for quite some time ..it did not cycle back and forth with each push of the knob...it stayed on...demo mode ON....

I will try it for the 25th time..

lilmaniac2
03-09-2008, 05:40 PM
if you read the manual you would see it there, I dont know why ppl cant find it. I installed on in a buddies ride and he couldnt find it in the manual or in the options either

tEh koRnDog
03-09-2008, 05:41 PM
:wacky:

edzy
03-09-2008, 05:49 PM
Stand by mode >menu>Demo If you push the knob in and push to the right/left and hold for 5-10 seconds.

edzy
03-09-2008, 05:57 PM
http://inform3.kenwoodusa.com/manuals/KDCX990.pdf

Page 53

BobbyDD
03-09-2008, 05:58 PM
Don't worry about the people telling you to read the manual. Yes, it's in there but it doesn't work like it's supposed to a lot of times. Call the Kenwood phone number (1-800-536-9663) and have them guide you through it. I had to call them and they were very helpful. Good luck.

gentlejax
03-09-2008, 07:23 PM
I found it in the manual and I was following the directions...I believe I said that 2x

....the deck wasnt accepting my input...

anyhow....I got it......

to those that tried to help ..thanks

edzy
03-09-2008, 09:29 PM
so how did you get it off? Please share.