PDA

View Full Version : need some help with a car



04_edge
02-24-2008, 01:30 AM
so my friends car all of a sudden started acting weird today...when he goes to start his car there is a loud clicking noise, and the engine doesnt turn over at all...also all the electronic stuff is acting wierd as well...i dont think the battery is dead...any ideas?

Millertime1028
02-24-2008, 05:34 AM
I'd check the battery again . Give it a jump and see what happens .

Jake The Snake
02-24-2008, 05:42 AM
Sounds like it may be the flux capacitor.

Screnzo
02-24-2008, 05:43 AM
Check the battery terminals, maybe give them a good cleaning/sanding/wirebrushing and tighten them back down. Make sure theres no massive corrosion on the battery cables and that the cables are fairly intact.

Millertime1028
02-24-2008, 05:46 AM
Sounds like it may be the flux capacitor.

Hate when these go bad !

Jake The Snake
02-24-2008, 05:47 AM
It happens.

savagebee
02-24-2008, 06:00 AM
contact our croatian forum member, he has access to plutonium, as well as uranium to rebuild the flux cap

fair prices as well

Jake The Snake
02-24-2008, 06:01 AM
Terrorists FTMFW!

04_edge
02-24-2008, 11:13 AM
I'd check the battery again . Give it a jump and see what happens .

actually i started thinking that maybe the battery has enough power to run everything else, but just not to turn it over...sure enough thats what it was.....

it was acting really wierd though, ive never seen anything like that before...

1FstFormulaV8
02-28-2008, 04:24 PM
Take the battery to a local parts store. I know we do..Advance employee. It sounds like the battery. How old is it?

$ Big C $
03-12-2008, 06:50 AM
a bad battery can cause weird problems.

frankjuda
04-09-2008, 10:41 PM
if its a clicking noise its going to be a problem with your starter solenoid or the started or the batt itself. like eveyone else said check the batt first then start looking into a starter and noid if the problem continues

Alpine CDA-9815
04-09-2008, 10:43 PM
Battery.

Automatic Juan
04-12-2008, 03:17 PM
Notwithstanding some of the ridiculous responses here, I'd agree with everyone who's thinking it's the battery. Or the starter.

My VW Bug exhibited similar symptoms some months ago; it turned out to be the starter bendix. You can take some steps to troubleshoot: can you start the car with a push? (only if it's a stick shift). Have you tried putting in a battery you know that works from another car? Also, clean out the batt contacts like others have mentioned.

Ferendon
04-13-2008, 12:40 AM
actually i started thinking that maybe the battery has enough power to run everything else, but just not to turn it over...sure enough thats what it was.....

it was acting really wierd though, ive never seen anything like that before...

Read, fvcktards... He solved the problem.

wErd
04-14-2008, 11:48 PM
haha, OP is a newb.