PDA

View Full Version : Kenwood KDC-X891?



Anonymous
01-09-2008, 06:12 PM
I am running one of these and I get feedback through my subs when a CD is loading, it sounds like the subs are humming. I can listen to the radio and the USB, flash drive, without any feedback from my subs, I was wondering if anyone else has experienced this type of problem with this HU and if so what did you do to get rid of the feedback. As I said it is only when loading a CD and when changing tracks on a CD. The other sources USB, AUX, and radio are noise free. I changed out my RCA's so it is not that and I added another ground to the back of the radio so it is not that. Any help would be appreciated.

Anonymous
01-09-2008, 06:16 PM
Nobody

redrocket
01-09-2008, 09:01 PM
I have the x790 and I've never had that problem or heard of anyone with it. I would figure the RCAs or the ground also but you've eliminated those.

Anonymous
01-10-2008, 09:23 PM
Anybody else? As I said RCA's have been replaced, ground has been added, what else could it be? Could it be a faulty radio?

Konstantin
01-10-2008, 09:55 PM
I had the x890 and I had humming coming from the screen and the cd player. Now I got a x991 and I got the same noise from the screen and the cd player.

Using USB, Tuner, or Aux doesnt have the humming noise...

I think I will be using the USB from now on.

Edit: noise comes from the HU, not subs/speakers. But still, its somewhat related :P

Anonymous
01-12-2008, 04:23 PM
So what I am experiencing out of my CD function is normal. Is there any way to fix it? I have already added a ground and changed my RCAs what else can I do? Or do I need to try and have it looked at, it is under warranty? Or should I cut my losses and just give up on the CD function and use the USB, AUX, and tuner, it is the 2nd HU I have been through. It is just that I have about 500 CDs that I really like and I really listen to alot, I would like to get it to where it is noise free on my CDs

Konstantin
01-13-2008, 02:39 PM
I really, really love the HU, it has many functions I wanted and I wont be changing it anytime soon (plus, the SQ is excellent). Yesterday I switched from CDs to USB and the cd reading noise is gone, all is left is the screen humming which is inaudible with music playing.

Its up to you, but at least I will be keeping mine :P

Also, if anyone knows a possible way to fix the noises, do tell.

Gary S
01-13-2008, 08:04 PM
I know some of the kenwoods have chassis mount rca jacks for front and rear outs, but pigtail outs for sub... perhaps that is the culprit... pigtails have been known to pick up noise. Maybe you could try a head with all chassis mounted rca jacks and see if the noise goes away. I think Pioneer might be all chassis mounted?