PDA

View Full Version : damm you saturn!



bannock
01-01-2008, 11:08 PM
Ok, got a few problems with the ol satty again.
First off, drivers power lock wont work. last winter after washing it something froze and i couldnt close the door. so after 45 mins of a screwdriver to it, it finally closed. but now i cant use the power lock. any ideas?
2. The check engine and ebrake light are always on, every now and then they will turn off but not for long. is there a reset button or something to make it go away?
3. while installing my dvd player i must have fried something because the car wouldnt start. Dad installed a small wire from the battery ( brains tired, the side thats black not red) to a metal part which makes me think something is grounding out? On the highway when i turn my high beams off, my stereo and anything else i have on will turn off and on. is it that wire that i have to replace? it looks a little beat up so thats my guess. ( ill get pics in the morning)
4. While driving, i notice alot of creaking and other noises of that nature comming from the front passenger and driver side wheels or area. ball joints?

I think thats about it, if anyone can shed light on any of these that would be great. And i will not accept the anwser "its a saturn, what do you expect" or anything like that as i know, i didnt have the luxury of time when i was looking for a car. Dont worry my next choice will be better. i wont let car audio.com down.


Oh, happy new yr too!

Qbenjamin
01-01-2008, 11:09 PM
check engine lights comes on for a reason, get it looked at ASAP.

DBfan187
01-01-2008, 11:11 PM
hook an OBDII upto it and see what code it's giving then look that up.

bannock
01-01-2008, 11:15 PM
i only didnt worry about it cause it came on after i was having problems with my electrical ( see the wire story lol)

wite2nr
01-02-2008, 04:58 PM
check all your fuses (under hood AND in passenger compartment). replace, as needed. that should fix some of the problems.

jco1385
01-02-2008, 04:59 PM
hook an OBDII upto it and see what code it's giving then look that up.

this is the best answer

Ferendon
01-03-2008, 02:08 AM
Ok, got a few problems with the ol satty again.
First off, drivers power lock wont work. last winter after washing it something froze and i couldnt close the door. so after 45 mins of a screwdriver to it, it finally closed. but now i cant use the power lock. any ideas?
2. The check engine and ebrake light are always on, every now and then they will turn off but not for long. is there a reset button or something to make it go away?
3. while installing my dvd player i must have fried something because the car wouldnt start. Dad installed a small wire from the battery ( brains tired, the side thats black not red) to a metal part which makes me think something is grounding out? On the highway when i turn my high beams off, my stereo and anything else i have on will turn off and on. is it that wire that i have to replace? it looks a little beat up so thats my guess. ( ill get pics in the morning)
4. While driving, i notice alot of creaking and other noises of that nature comming from the front passenger and driver side wheels or area. ball joints?

I think thats about it, if anyone can shed light on any of these that would be great. And i will not accept the anwser "its a saturn, what do you expect" or anything like that as i know, i didnt have the luxury of time when i was looking for a car. Dont worry my next choice will be better. i wont let car audio.com down.


Oh, happy new yr too!
1. Depending on what you were messing with, you may have dislodged the lock rod from the door latch assembly. Should just slide back into place, but you'll have to remove the door panel. If this is the case, the lock arm probably won't move at all, other than a possible slight twitch, when you hit the switch.


2. Check Engine light, just get it scanned. Parking Brake light, check your brake fluid. If that's not it, then the scan should catch the problem.


3. Pics possible? And the black side is ground. :)


4. Could be lots of things. Could be the brake shield rubbing the strut assembly, or it could actually be a worn part. Suspensions can squeak for lots of reasons. Basic suspension troubleshooting is easy, but then again, it's only basic. Jack a tire off the ground a couple of inches. Grab the top and bottom of the tire at the same time, and see if it 'teeter-totters'. Repeat this, while holding the sides of the tire. Then grab the bottom of the tire and push and pull back and forth.

Play from top to bottom, could be a wheel bearing, or lower control arm/ball joint. Side to side, wheel bearing or tie rods. If it's a wheel bearing it will have play from top to bottom AND side to side. If the bottom of the tire moves in and out, then it could be LCAs/ball joints, strut mount, or tie rod end.

top to bottom and side to side = wheel bearing, combination of things
just top to bottom = LCA/Ball joint
just side to side = tie rod, most likely the outer, but always doubt the inners as well.
just in and out = LCAs on the way out, but not shot just yet, or strut mount. If it's a strut mount, it will usually knock loudly when you hit a bump.

There's much more to it than that, but with a little common sense, a good look at the suspension set up, and a few wiggles and shakes, suspension problem are usually not too hard to figure out.

DSMW
01-03-2008, 02:12 AM
check engine lights comes on for a reason, get it looked at ASAP.

not true at all. sensors can be fasley set off and when it even gets wet, it will go off. and yes i use to own a 1996 saturn, i know about the engines. mine always tripped in the rain, and then would go off.

Ferendon
01-03-2008, 02:28 AM
If that's the case, then pull the codes, find the corresponding sensor that would generate such a code, and clean/dry it and the connector(s), and re-install it.

azbass
01-03-2008, 01:45 PM
Parking Brake light, check your brake fluid. If that's not it, then the scan should catch the problem.


your break fluid should have nothing to do with a parking break...

and a scan wont fix that either..

Ferendon
01-04-2008, 12:23 AM
A lot of cars use the e-brake light to indicate low brake fluid though.

bannock
01-10-2008, 02:18 AM
Ferendon:
1. Depending on what you were messing with, you may have dislodged the lock rod from the door latch assembly. Should just slide back into place, but you'll have to remove the door panel. If this is the case, the lock arm probably won't move at all, other than a possible slight twitch, when you hit the switch.

i tried that, and then i could only lock the door manually and not from the power lock.

the brake fluid is always topped up so i dont think that its. once i have a chance ill check the fueses.

check engine light is off for now and i didnt do anything haha.

pics of the ground good, camera is being gay, thanks so far guys

memphis_vette
01-10-2008, 02:25 AM
your car if messed up...my option get it fixed

Ferendon
01-11-2008, 12:46 AM
On the ebrake light, you might need to clean the contacts on the reservoir cap. If you look at your reservoir cap, you'll see a small rubber cap covering the middle. Take the whole cap off the reservoir, remove that rubber cap, push up on the float to separate the two contacts, and then spray them with brake parts cleaner, or electronic contact cleaner. This is also assuming you have a brake fluid level sensor on the car.
Could also be the actual switch on the ebrake assembly.