PDA

View Full Version : '94 Galant Help



Galant07
12-28-2007, 05:45 PM
..I have 2 major problems.....1..my back lights will not go OFF..i have 2 unplug them or else they will run my battery down....2...its this wire that seems to have burned off to whereever it came from and if it isnt touch the pos on my battery the car is in dead mode..i mean no nothin..no engine movement..light..nothing!!..straight dead mode...i have it tied to the pos terminal...i mean..its a pink wire ..if that wire comes loose then the car doesnt not move...anything..i need help!!

Ferendon
12-29-2007, 01:54 AM
What do you mean by 'back lights'? Reverse lights or tail lights? And where is said pink wire located?

SilverSquared
12-29-2007, 02:37 AM
reverse light switch, or fuse. Check the fuse. if there is none, or its still good. Move on to the reverse light switch. Better yet, replace that anyway. Go to autozone and ask for a Haynes Repair Manual. Keep that in the car at ALL times. Incase something like that happens when you arent at home.

bumpincrv
12-29-2007, 02:39 AM
if its the brake lights could be the brake light switch or even brake pedal or switch just sticking try pullin back on the brake pedal

bumpincrv
12-29-2007, 02:39 AM
if its the brake lights could be the brake light switch or even brake pedal or switch just sticking try pullin back on the brake pedal

Galant07
12-29-2007, 08:30 PM
What do you mean by 'back lights'? Reverse lights or tail lights? And where is said pink wire located?

tail lights stay on...the pink wire is like coming from the black box that has them bigger fuses ..and wherever it was connected to its not anymore..and i have 2 have it on the pos+ terminal or else the car is in dead mode..so whatever it goes 2 it had 2 been connected somewhere under that black box cuz thats where its coming out of...?