PDA

View Full Version : Well I just did dumbest thing of my installing...help?



NJTStang11
12-21-2007, 01:38 PM
Well for the past 3 months I've been without a system. Finally got everything together and of course I was in a big hurry. Went to install my CD player that I got used, so to check to make sure it worked I had my brother hold it up and I connected both powers and ground (yellow, red, and black). Well as I was doing so I cut my finger and let dropped the red/yellow. Needless to say it hit my ground and sparked. This happened after it powered up. I shut it off and as I was pulling the keys out the wires fell. So car wasn't on but battery WAS (I know I'm dumb and too lazy to unhook ground).

What kinda damage am I looking at here? Headunit no longer powers up.
Just a fuse? New power supply? Need to rerun a certain wire? Completely ****ed the CD player?

skeptikal
12-21-2007, 01:39 PM
Check the fuse in the back of the head unit. If it's blown just replace it and you should be okay. That's what fusing is there for.

If not... go buy a new H/u

dragnix
12-21-2007, 01:40 PM
check the fuses first, as long as u don't see smoke then i think u should be safe

Raffi
12-21-2007, 01:40 PM
Check the HU fuse, the Radio, Dashboard and Cig lighter fuse in the fuse box........

lilmaniac2
12-21-2007, 01:41 PM
should just be fuses

DBfan187
12-21-2007, 01:41 PM
http://www.democraticunderground.com/top10/06/268_nelson1.gif

NJTStang11
12-21-2007, 01:41 PM
Yea no evil gray smoke, first thing I checked for. Almost **** my pants when I heard that noise.

NJTStang11
12-21-2007, 01:45 PM
http://www.democraticunderground.com/top10/06/268_nelson1.gif

lol :crying:

NJTStang11
12-21-2007, 02:10 PM
Well almost freaked out there for a bit...

Checked back of HU, fuse ok.
Checked cigarette lighter, fuse ok.
Finally, check radio fuse, blown.

I pray this fixes it :veryhapp:

dragnix
12-21-2007, 02:13 PM
it should, same thing happened in my car :)

NJTStang11
12-21-2007, 02:15 PM
it should, same thing happened in my car :)

Last time I put in a CD player without unhooked the battery.

Thanks for the help guys.

Gary S
12-31-2007, 07:26 AM
Next time, disconnect the neg. batt. terminal before making any electrical connections... or next time, it could be a lot worse.

wite2nr
12-31-2007, 02:41 PM
also, check the fuse under the hood. Last time i hooked up a deck, i did the same thing, blew a fuse under the hood (like a 20A)

luvinthebass
12-31-2007, 03:55 PM
like a fire