PDA

View Full Version : can't hook up tweeter???



kodyvan20
12-17-2007, 10:18 PM
I have a 2007 Mercury Milan with the 6 speaker set up. I am replacing the four door speakers with some Alpine SPS-57C2 2-way 5X7's. I planned on keeping the stock tweeters in. The box the speakers came in said: This product contains a high performance tweeter. If there is a tweeter already installed in your car, then you must disconnect its terminals. If you leave the original tweeter connected and connect this product in parallel, then a fault may develop in this product, so you are strongly recommended not to do so. I just need some expert advice on this. Do you really think it will mess anything up? Thank you.

bonesninja
12-17-2007, 10:22 PM
wow...........its right there in black and white. just for once, will someone please take the manufacturers advice

kingkong101
12-17-2007, 10:23 PM
i honestly dont see how that could fault it.. but sure disconnect em..

bonesninja
12-17-2007, 10:25 PM
well the alternative is to hook it up and then when your speakers fault out...you can come ask everyone for advice on which speakers to buy next time.


in all honesty, you'll probably be fine but why take the chance?

kodyvan20
12-18-2007, 11:23 AM
wow...........its right there in black and white. just for once, will someone please take the manufacturers advice


I am just trying to figure out why they would fault out.

andrewmoore13
12-18-2007, 11:27 AM
i have learned that you don't need to know why things happen... they just can/do

kodyvan20
12-18-2007, 11:30 AM
i have learned that you don't need to know why things happen... they just can/do

It would still be nice to know.