PDA

View Full Version : 1999 Mitsubishi Galant Problem???



revrider1
10-25-2007, 11:14 AM
Ok, heres the deal...

I have a 1999 Mitsubishi Galant, last week it began to somewhat pull on the highway. I also noticed as if the tranny was forcing itself. I figured id change my fluids becasue it didnt seem as if it was going into 5th gear or overdrive...

I took it to the shop and to my knowledge the car has a 4 speed tranny and no overdrive :confused:. SO my theory was no longer an objective. I went ahead and changed the fluid and that didnt work...

Heres what its doing, if anyone has knowledge of this car and could help or give me an suggestion. On the highway going 70mph its at 2750rpm's, seems very high to me for it to be running at that high an rpm :wow:. Then on a downhill it seems to pull or jerk back a bit. I know a little about cars, but when it comes to foreign front wheel drives POS cars im clueless...

If anyone can help I would much appriciate it... :)


Thanks ;)

Rev

revrider1
10-25-2007, 03:23 PM
Anyone???

Ferendon
10-25-2007, 10:49 PM
That doesn't seem to be very high RPMs for a 4-speed auto... And it's a 99 Mitsu. Wouldn't be surprised to see the tranny go to pot.

95BlackGA
10-25-2007, 10:54 PM
I have that same problem with my '96 Mystique. 4 Speed Auto FWD. Go have the tires aligned, and see if the tires have abnormal wear on them. (I.e. on side is wore more than the other side.)

revrider1
10-25-2007, 10:56 PM
Ok, any others?

Rich B
10-25-2007, 10:59 PM
You really need one of these-
http://www.harborfreight.com/cpi/photos/94100-94199/94169.gif

An OBD II scanner to read any trouble codes your car's ECU (computer) is dealing with.

About $40 from Harbor Freight.
http://www.harborfreight.com/cpi/ctaf/displayitem.taf?Itemnumber=94169

A real lifesaver when it comes to dealing with modern cars made after 1996.

JoeHemi57
10-25-2007, 11:00 PM
its a 4 speed auto with overdrive. rpm's are about right, not a whole lot of tranny problems in my experience though.

revrider1
10-25-2007, 11:01 PM
I was thinking about going to get one...

The service light is not on by the way

revrider1
10-25-2007, 11:02 PM
its a 4 speed auto with overdrive. rpm's are about right, not a whole lot of tranny problems in my experience though.I was told it has no overdrive by the dealership...

Rich B
10-25-2007, 11:06 PM
I was thinking about going to get one...

The service light is not on by the way


My 2001 Eclipse didnt throw an SES today, but it died on the freeway anyway.:crying:

Plugged in the scanner and it said the camshaft position sensor went out.:verymad:

Ferendon
10-25-2007, 11:08 PM
Cam sensors are easy. At least it wasn't the CKP.

revrider1
10-25-2007, 11:10 PM
Ok, im getting confused, lol...

Are you all saying its the cam sensor going bad or CKP?

JoeHemi57
10-25-2007, 11:19 PM
I was told it has no overdrive by the dealership...

lol, i was parts manager for Mitsubishi for 3 years in little rock, nobody has had an auto without an overdrive in years. they are however, like most 4 cylinders geared very low,(high numerically) due to the lack of power.

JoeHemi57
10-25-2007, 11:20 PM
also what fluid did you use?

revrider1
10-25-2007, 11:24 PM
Diamond, the recommended from mitsubishi...

So ur saying its normal to run at 2750rpms on the highway doing 70mph?

JoeHemi57
10-25-2007, 11:29 PM
thats not that high, my moms prelude runs over 3k

revrider1
10-25-2007, 11:31 PM
Dam, got that cleared up...

ok then can you help me with the issue of it pulling on the downhill?

Rich B
10-25-2007, 11:33 PM
Cam sensors are easy. At least it wasn't the CKP.

On a 4cyl, it sure is.

Thank goodness its not a 6 cyl, otherwise I would need a whole new distributor.


And revrider, I only posted my experiance from today to try to point out that the SES light doesnt always come on if theres a problem.

IM sorry if you thought I was suggesting you have the same problem.
:)

revrider1
10-25-2007, 11:34 PM
Cool, I was already all nervous thinking im getting into a big repair..

revrider1
10-26-2007, 02:56 AM
Ok, I just got home and now its jumping into 4th gear...


Ahhh...

Maybe my tranny is going out, dammit...

Ima try and go get a code reader tommorrow so I can answer all my questions...