PDA

View Full Version : My indepth review of MB Quart PAB4100 and 1200.1D



HmoobVaj
10-22-2007, 03:26 PM
These are MB Quart's 2007 line up of their Premium series ampilifiers.

Aesthetics
The first things you’ll probably notice about these amps are that they’re huge. The 4 channel 4100 is 18” long and the mono 1200.1 is 17”. After you get over their size you’ll start appreciating the clean and simple yet very elegant looking amps. The exterior is wrapped in black brushed aluminum with the MB Quart logo in large white letters in the center. The red rectangle is illuminated when the amp is on. There are also vent holes on the top covered with mesh screens. No heatsink fins are visible. The input and output connections are on the right and left sides hidden behind detachable endcaps. There does not seem to be any fans for cooling.

Connectivity
As I have mentioned above the connections are hidden behind endcaps on both left and right sides. You may initially think that this design gives a much cleaner appearance since all the wiring are hidden. Well that may be true if it was properly designed. The Germans failed terribly here. Once the endcaps are removed you’ll notice the heatsink edges around the connections are very sharp. And yes, sharp enough to cut your hands and fingers. I got 2 cuts and one of them was so deep I almost needed stitches. The rca inputs aren’t too hard to get to but the power and speaker outputs are a nightmare. You have a 2 inch height and 2 inch depth clearance to work within and that’s not a lot. Did I forget to say that the screws for the connections are only accessible from underneath? So if the amp is mounted on a board you have a clearance to stick a hex wrench to get to the screws. Since I had the amp mounted on a board before connecting the speaker wires it took me 30 minutes just to connect 2 pairs of speaker wires. I then had to unmount the amp to connect the power wires. If I knew how difficult it would be to install these amps I would probably have passed on them.

Output
The 4100 a class A/B design rated at 100w x 4 @ 4ohms. The output from my components up front and coax’s in the rear sounds like the rating is pretty spot on, neither underrated nor overly exaggerated. The 100 watts to each of the rear helped dish out more midbass than the 25w from the JL 500/5 I had before. The 1200.1 is a Class D mono amp rated at 600 x 1 @ 4ohms, 800w @ 2ohms and 1200w @ 1 ohm. I think I may have received a defective one though. I have it pushing 2 10” JL W6 with a final load of 1.5 ohms. According to the specs at 1 ohm it should be pushing 1200 watts rms so at 1.5 I should be getting somewhere around 1000w. Sounds as though I’m only getting about 200w. The 250w from the 500/5 was kicking way louder and deeper. I have double checked all my wirings and settings and they are fine. I’m currently working on getting the amp replaced from the store I ordered it from.

Final words
I can’t really say I’d recommend these amps at this moment due to the possible defective mono amp I received. If the replacement I receive fixes the low bass output problem then I’ll recommend them if you’re willing to work pass the poor connectivity design. Prepare for plenty of nicks, cuts and scratches though.