PDA

View Full Version : Need Chevy Tahoe/Truck help, please.



Eugenics
10-14-2007, 10:20 PM
I recently purchased a silver 99 Tahoe LT. I love the vehicle, but there are some problems and i'd really appreciate some help.

Some of the lights on the stereo dont work at times, some never do. The thing is that when the eject and recall buttons on the HU don't work, neither does the passenger seat heater. Since that is where my girlfriend sits, its very important that i get it fixed. Or i will have a constant nagging noise coming from that region of the vehicle.

In addition, little lights around the vehicle just dont work, the lights for the window switches and mirror toggle/switch/whatever, and other random lights. Its just annoying, and i'd really like to fix it.

The Lock on the drivers side door is giving me problems as well. It works manually, but when i use the keyless entry remote to lock or unlock it, sometimes it doesn't unlock, or lock completely, so i end up having to use my key.

The right side mirror housing is broken, the mirror itself works fine, its just the housing. It's epoxied together, it functions fine, its just an eyesore.

As well i would like to replace the drivers side seat, as the leather is work out on the left side. Where should i look?

Any help or insight would be very well appreciated. The headunit will probably be replaced, but i'd still like to figure out whats going on with the seat heater and what the fix is.

Eugenics
10-14-2007, 10:40 PM
answer my problems to help me fix my hoe, hoes.

Calikid
10-14-2007, 10:44 PM
that's why u inspect cars before u buy.:p:

Calikid
10-14-2007, 10:45 PM
or u didn't give a Fvck?

Acidburn
10-14-2007, 10:47 PM
a stiff back hand is the fix to that nagging noise

NeverEnuffBass
10-14-2007, 10:49 PM
I recently purchased a silver 99 Tahoe LT. I love the vehicle, but there are some problems and i'd really appreciate some help.

Some of the lights on the stereo dont work at times, some never do. The thing is that when the eject and recall buttons on the HU don't work, neither does the passenger seat heater. Since that is where my girlfriend sits, its very important that i get it fixed. Or i will have a constant nagging noise coming from that region of the vehicle.

In addition, little lights around the vehicle just dont work, the lights for the window switches and mirror toggle/switch/whatever, and other random lights. Its just annoying, and i'd really like to fix it.

The Lock on the drivers side door is giving me problems as well. It works manually, but when i use the keyless entry remote to lock or unlock it, sometimes it doesn't unlock, or lock completely, so i end up having to use my key.

The right side mirror housing is broken, the mirror itself works fine, its just the housing. It's epoxied together, it functions fine, its just an eyesore.

As well i would like to replace the drivers side seat, as the leather is work out on the left side. Where should i look?

Any help or insight would be very well appreciated. The headunit will probably be replaced, but i'd still like to figure out whats going on with the seat heater and what the fix is.

Probably want to take a look at the little actuator that opens and closes the lock, might be time for a new one

ryanroma
10-14-2007, 10:51 PM
Advice on the mirror: get a genuine GM one or customs, because the replacements from AAP, O'Reilly, etc. will shake like a fatty ***. As far as the seat heater and HU problem, check all the connections; if it works sometimes but not others, prob. just shaking loose.

Eugenics
10-14-2007, 10:56 PM
that's why u inspect cars before u buy.:p:

Everything else with its fine pretty much, these are just age related issues, not something i could avoid regardless of who i bought the vehicle from.


a stiff back hand is the fix to that nagging noise

We're past that point in our relationship, we use a good old fashioned closed fist now.


Probably want to take a look at the little actuator that opens and closes the lock, might be time for a new one

How much are those? Are they easy to install?

Thank you


Advice on the mirror: get a genuine GM one or customs, because the replacements from AAP, O'Reilly, etc. will shake like a fatty ***. As far as the seat heater and HU problem, check all the connections; if it works sometimes but not others, prob. just shaking loose.

I'm planning on getting one from a salvage yard or something. Want to use as many original parts as possible. The mirror itself was going to be $500 to replace, so i'm hoping i can find a housing easily.

I'm hoping the seat heater issue will be resolved once i install a new HU.

Calikid
10-14-2007, 11:03 PM
seats (http://cgi.ebay.com/ebaymotors/New-Chevy-Suburban-Tahoe-Mid-Captains-Leather-Seats_W0QQcmdZViewItemQQcategoryZ33701QQihZ009QQit emZ190161443901QQrdZ1QQsspagenameZWDVW)

Eugenics
10-15-2007, 01:16 AM
seats (http://cgi.ebay.com/ebaymotors/New-Chevy-Suburban-Tahoe-Mid-Captains-Leather-Seats_W0QQcmdZViewItemQQcategoryZ33701QQihZ009QQit emZ190161443901QQrdZ1QQsspagenameZWDVW)

I want some stockers :-/

RipDaJacka
10-15-2007, 01:23 AM
bruh i think that Door lock issur might be a problem in the future.. I had a 1997 Explorer and the Lock would not work completely and basically have the same issue as you stated... then one day the locks button stopped working completely... shortly after the power windows would stick while rolling down...and one day they all stopped rolling down...so i ended up with 1 door that would not lock unless i used the key... and no rolling windows... I even went as far as having the whole switch panel changed for a new one and it did nothing to help it...any of it!! I sold the truck before it was fixed so i dont know a solution...but look into having it fixed before it worsens

BreakingBad
10-15-2007, 03:09 PM
buy a new car?

lmao

Eugenics
10-15-2007, 03:13 PM
buy a new car?

lmao

quit getting sand in your ****** because women dont take you seriously?

lmao

Flipx99
10-15-2007, 03:15 PM
Bet corroded grounds causing the wiring issues.

Might wanna remove the panels and wiggle the wires a bit...see if they come on.

Eugenics
10-15-2007, 03:16 PM
Bet corroded grounds causing the wiring issues.

Might wanna remove the panels and wiggle the wires a bit...see if they come on.

Alright, what do i do if the problem is infact the grounds? How do i diagnose and then solve the problem?

Thanks.

Flipx99
10-15-2007, 03:18 PM
sand it down and reground.

What happens most is the wires wiggle themselves out of the harness. That happened on my truck.

It's a pain in the *** to search through all the wiring, but it's the only way. If problems where happening to both sides, you could look at the switch itself....

It's hard to see without looking at it more in depth...or spending a bunch of money replacing parts.

As for the HU, are you going to put a deck in there? If so, why does it matter if the buttons do/do not light up?

Eugenics
10-15-2007, 03:26 PM
sand it down and reground.

What happens most is the wires wiggle themselves out of the harness. That happened on my truck.

It's a pain in the *** to search through all the wiring, but it's the only way. If problems where happening to both sides, you could look at the switch itself....

It's hard to see without looking at it more in depth...or spending a bunch of money replacing parts.

As for the HU, are you going to put a deck in there? If so, why does it matter if the buttons do/do not light up?

It doesn't, its that the seat heater is effected. I could care less about the factory HU as long as the tape deck works.

Going to start looking for a 7998, might just go with the 9887 though.

Flipx99
10-15-2007, 03:29 PM
I can't even find a broken 7998....I tried to offer $50 for one that won't even come on and the guy gave it away or something...

Flipx99
10-15-2007, 03:30 PM
I wouldn't think the two where related. It may just be the switch. Try to pop it out and clean it with that electrical parts cleaner that Low'es sells. Switch it with the other side. If it lights up then, there is something wrong with the wiring...if it doesn't, the light in the switch may have went out.

Hopefully, that is clear.

SethPhillips
10-15-2007, 05:10 PM
the actuators are gumming up... seen a few do that. most of the time you can get away with sprayin it with a little wd40 on the linkadge... if that dosent work. replace it. and acutaor runs about 15-22 $. each.

the light bulbs prolly need to be replaced on all the thing's not lighting up..

and rmember what baby powder said. DI*K DRIVE THIS CAR. NOT PUS*Y.

and as far as the heater on the pass side...... i would check behind the headunit and see if you got a wire loose or something....

deffinitly give the vehicle a once over AT LEAST before you buy a headache. or another nagging broad

Eugenics
10-15-2007, 05:25 PM
the actuators are gumming up... seen a few do that. most of the time you can get away with sprayin it with a little wd40 on the linkadge... if that dosent work. replace it. and acutaor runs about 15-22 $. each.

the light bulbs prolly need to be replaced on all the thing's not lighting up..

and rmember what baby powder said. DI*K DRIVE THIS CAR. NOT PUS*Y.

and as far as the heater on the pass side...... i would check behind the headunit and see if you got a wire loose or something....

deffinitly give the vehicle a once over AT LEAST before you buy a headache. or another nagging broad

ill mess with the linkage when i install the speaks, and ill check the lights around then too. thanks!

SethPhillips
10-15-2007, 05:29 PM
ill mess with the linkage when i install the speaks, and ill check the lights around then too. thanks!

a buddy of mine has that year suburban and he had gone in and replaced EVERY bulb in the dash with blue L.E.D.'s and i likey

Eugenics
10-15-2007, 05:37 PM
a buddy of mine has that year suburban and he had gone in and replaced EVERY bulb in the dash with blue L.E.D.'s and i likey

So they're all LED's? then i'd just have to do some solder work or something.