PDA

View Full Version : eclipse cd5100 - cd/motor stuck?



BreakingBad
09-24-2007, 10:25 AM
was listening to music like usual today, then all of a sudden the cd stopped playing, "skipped" around. i pressed teh cd eject button, motor face plate went down, but cd didnt eject like normal. tried pressing eject button, did nothing.

faceplate is stuck in eject position... tried turning car off/on, didn't reset it. theres no emergency eject button. how do i get the cd out/reset the player?

mike4d
10-14-2007, 09:21 PM
the exact thing just happened to me, my cd5100 stopped playing and will not eject the cd. I never really even used the cd player, i just plugged in my thumb drive and listened to music from there. this is only about the second cd i've ever played in it, and now it is stuck. if anyone out there knows of a way to get the stupid cd out without dismantling the unit, please post.

the727kid
10-14-2007, 09:24 PM
Are you sure the face went all the way down, on my cd5000 the dash kit prevented it from going completly down by like an 1/8th inch and that was enough not to eject the cd, I would have to tap the face up and it would eject.

crx4luke
10-14-2007, 09:35 PM
Try taking the radio out of the dash to see if that releives some pressure on the faceplate. i had a problem with a cd7000 doing the same thing because the face didn't have enough clearance to come all the way down.

mike4d
11-12-2007, 11:32 PM
yeah, the cd door had plenty of clearance. it finally spit out the cd the other day. i didn't do anything special, i just decided to give it another shot and it just worked. not sure exactly what the problem is. for the amount of money i spent, it is very dissapointing that this happening, even though i only use the usb port and almost never listen to cd's.