PDA

View Full Version : Pioneer Nav Discs Inaccuracy...



Qbenjamin
08-10-2007, 08:38 PM
I am sooo frustrated with the inaccuracy of these nav discs. I have owned the N1-N3, and never had this problem. I also had the Avic D2 before I bought the new D3 this year. Has anyone else had this problem? I had a conference to go to in Mobile, AL earlier this year, and the Nav dics was about a mile off. I brushed that one off as a "Well it's not perfect," now yesterday, I was trying to find a firestation in a city right outside of mine, and the navi took me about 4 blocks the wrong way after the final turn. I have noticed this before with trying to find houses, but with PUBLIC SERVICE LOCATIONS? WTH? I emailed Pioneer about the discrepancy, but they haven't gotten back to me yet. I just wanted to know if anybody else that has the newer Avics seem to be having this problem? :rage:

Qbenjamin
08-11-2007, 10:40 AM
So I guess I am the only one with this problem huh?

Louisiana_CRX
08-11-2007, 12:14 PM
I've noticed the Navigation system is off quite often...I have a AVIC Z1 and just recently sold my AVIC D2 for $500 which wasn't very accurate either...I bought a JVC 5000 and I'm gonna give that navigation system a try...

Qbenjamin
08-11-2007, 12:23 PM
I've noticed the Navigation system is off quite often...I have a AVIC Z1 and just recently sold my AVIC D2 for $500 which wasn't very accurate either...I bought a JVC 5000 and I'm gonna give that navigation system a try...


I have been looking at the Eclipse nav's, and I think I am going to give those a try. Another thing that makes me mad is, the 2.2v pre-outs on the Pioneer units, they SUK.