PDA

View Full Version : why do my infinity's **** balls



cooley346
07-05-2007, 11:45 AM
I got some infinity reference 5010's. 5 1/4's plus the tweets with crossover. They sound horrible compared to my factory GM setup which is just the 5 1/4's plus tweets with no crossover, just spliced wired running to both. what's wrong with this pic. These have great reviews on all the car audio review boards. They weren't cheap either when they came out. $200 plus the ones for the rear deck which were like $250 but I haven't installed them yet as I'm afraid they'll sound like crap too. what gives. please help.

ThatChevyGuy
07-05-2007, 11:49 AM
i hope ur using an aftermarket amp.

djman37
07-05-2007, 11:54 AM
proper install would be important.
They first need to be properly mounted in the door, not just sheet metal screwed on.
Secondly, the signal feeding them needs to be good. Typical head unit power blows. Get them on an amp. With a clean signal and plenty of power, they should shine above stock setups(this does not include SOME premium systems)

Louisiana_CRX
07-05-2007, 11:54 AM
hmmmmm...phase problem :confused:

ultimate157
07-05-2007, 11:56 AM
Sounds to me like you just put them in place of your factory speakers? If so, you need to run everything new from an amplifier to really let aftermarket speakers shine. Stock power and equipment really hamper the equation.

cooley346
07-05-2007, 12:25 PM
I ran them off an a small mtx amp and it did no good

Racerx250
07-05-2007, 12:37 PM
I had a situation somewhat like this. I had the 6010cs on a HU and they clipped terribly. So I decided to put em on a kx600.4 and now they sing.

99galant
07-05-2007, 05:44 PM
it could be that inifinity isn't that good anymore. I haven't ever been impressed with them so the result isn't suprising to me. I would check the install of the speakers and also consider if using the factory HU and/or the amp. Also give us some details as to what ***** about them.

req
07-05-2007, 05:46 PM
because infinity ***** arse.

shortyg83
07-05-2007, 05:53 PM
So you ran them of all small mtx and they still ****? meaning you took apart your car ran new rca's ran new speaker wire then retested everything. I dont believe you, you posted that comment 1 hour after the original. I have a set of infinity reference 5.25 comps right here at my house from my last install and they sounded great. they were amped.
Also what setting do you have for the tweeter on the crossover?

ToyTundra
07-05-2007, 11:43 PM
I find that chevy's stereos sound pretty good so it will take more than an entry level component set to impress you. As said before the install is everything. I did not like my Infinities.

Makaveli7haDon
07-06-2007, 12:40 AM
one word.............INSTALL. it should not "****" if setup correctly. That means with the proper power, wiring, deadening....etc

bdawson72
07-06-2007, 12:41 AM
because they are your's :fyi:

Brian_smith06
07-06-2007, 01:36 AM
i have a pair of kappa 3 1/2's in my old car and they sounded fine off head unit, no component set by no means but still sounded pretty good

tbasile1
07-06-2007, 10:01 AM
I also have Infinity coaxials, they sound good, something must be wrong in the install

Pickzilla
07-07-2007, 01:02 AM
Ok,

This is jst my experience, not by any means trying to flame.

Infinity speakers are horrible. Period.

I ran a set of kappa 6x9s for rears and a set of perfect 6.1s for front comps. I ran them for about 6 months.

Nothing could help how horrid these speakers sound. I tried everything... months of tweaking, running different amps, etc.

They just are a crappy product. Infinity makes garbage... PERIOD.

I replaced them with CDTs, and man... am I glad.

theputz
07-08-2007, 01:02 AM
did you hook up the crossover that they came with?

tru_44
07-08-2007, 01:11 AM
because they are your's :fyi:

x2:D

DiamondFanatic
07-10-2007, 05:13 PM
did you hook up the crossover that they came with?

The OP mentioned that he wasn't running a crossover so I'm pretty sure he means he didn't install the included crossover. This is most likely the problem. You also failed to mention what car they are installed in.

konechiwa
07-11-2007, 09:12 PM
The OP mentioned that he wasn't running a crossover so I'm pretty sure he means he didn't install the included crossover. This is most likely the problem. You also failed to mention what car they are installed in.

OP: way to be stupid. they come for a reason. You're sending high frequencies to the woofers and lows to the tweeters.

They give you crossovers for a reason.

Plus you got ripped off. Their 120 dollars on crutchfield as we speak- and crutchfield is authorized.

hbfromkc
07-19-2007, 01:57 AM
All this **** talk about Infinity...does somebody have any they wanna get rid of?!