PDA

View Full Version : WTF? just wondering why it does this



SplChoice-
06-30-2007, 12:59 PM
alright i installed my c720s a while back and they played fine, now i put a kicker 350.2 on them and sometimes when i turn it up not even real loud loud cause those things can sing loud but they cut off to a lower volume then kick back in, even at lower volumes it does that any reason why?

afterbirth
06-30-2007, 02:19 PM
alright i installed my c720s a while back and they played fine, now i put a kicker 350.2 on them and sometimes when i turn it up not even real loud loud cause those things can sing loud but they cut off to a lower volume then kick back in, even at lower volumes it does that any reason why?

The lowered volume that you're hearing is the tweeter protection circuit doing it's job. That is why when you turn it down they kick back in.

SplChoice-
06-30-2007, 03:00 PM
well why does it do it at low volume to and just stop playing for a while then kick in outta no where, and these comps get loud and im not even getting those tweets kicking yet i dont understand gain is like almost all the way down

Krown
06-30-2007, 03:09 PM
I'm having almost the same problem with my MB comps... boo.

SplChoice-
06-30-2007, 03:51 PM
i know its weird man..i dunno why its doing that it pisses me off i hardly have it on and it shuts off then comes back on and when i turn it up i know they can get louder but then shutoff at low volume then come back on weird

afterbirth
07-02-2007, 12:10 AM
Are you sure your amp isn't bad??

SplChoice-
07-02-2007, 12:52 PM
well the amp works fine it seems to make them play, but then as i turn it up it will go low and the gain is low low there not even loud loud like they used to get, or when im driving and the volume is like midway it will cut out tooo, maybe it is the amp but i dunno.

afterbirth
07-08-2007, 01:31 PM
well the amp works fine it seems to make them play, but then as i turn it up it will go low and the gain is low low there not even loud loud like they used to get, or when im driving and the volume is like midway it will cut out tooo, maybe it is the amp but i dunno.

Sorry it took me so long to respond but it sounds like you have a bad amp if they're cutting out at any volume.

Just make sure you check ALL of your connections. I had a similar problem a couple of years ago. I checked all my speaker connections on my barrier strip and found a couple bad crimps that allowed bare wire to touch bare wire on another terminal and that shorted them both out. I fixed the connections and I was good to go.

Just something to think about.