PDA

View Full Version : Pioneer p80mp - Face motor blown?



myflow
06-09-2007, 11:46 AM
So I've had a Pioneer p80mp for a year now in my jeep, and yesterday, I went to eject my cd, and nothing. The face plate didn't come down. I'm assuming the motor's fried. I got it from Best Buy a little less than a year ago. Do all of their head units come with some type of warranty for this stuff? or am I screwed?

Any suggestions on how I can at least get my cd out of the deck or anything?

Fixxer
06-09-2007, 09:03 PM
So your deck doesn't turn on? or just doesn't eject? I was gonna suggest reset maybe but you are gonna lose all your settings.

bass_lover1
06-09-2007, 11:58 PM
So I've had a Pioneer p80mp for a year now in my jeep, and yesterday, I went to eject my cd, and nothing. The face plate didn't come down. I'm assuming the motor's fried. I got it from Best Buy a little less than a year ago. Do all of their head units come with some type of warranty for this stuff? or am I screwed?

Any suggestions on how I can at least get my cd out of the deck or anything?


Since you got it at Best Buy and they are an authorized Pioneer dealer, their basic units come with a 1 year warranty, and the Premier stuff comes with a 2 year warranty. If you still have the receipt you shouldn't have to pay anything to get it fixed.

kpozr2
06-10-2007, 12:04 AM
maybe the face is jammed? i know my alpine has been jammed a few times maybe a gear inside is jammed.

coolguy448
06-10-2007, 12:07 AM
i had a deh-p860mp and it did the same to me.

push the eject, it beeps, but no movement at all.

i had to take the top metal panel off the deck and nudge the gears that move the faceplate. it would get stuck like once a month and i did that each time. annoying, but it worked.

but i had no warranty, i suggest trying that route first.

myflow
06-10-2007, 03:41 PM
you know, I turned my jeep on today, and the faceplate worked again. I guess it was just temp. jammed or something. :\

***** though, it should work flawlessly. rawr.