PDA

View Full Version : Just got a 96 Blazer...



sqhertz
05-31-2007, 08:46 PM
:) !

Picked it up today. ill have pics later tomorrow.
just a couple questions though...

AC works , just doesnt blow out the dash vents. just the defrost and foot vents. any reason/fix for this?
also the heat doesnt blow hot at all , it just stays cold. i was thinking heater core cause i found water on the passanger floor board but it doesnt smell like **** like how everyone says it does when the core takes a ****. reason/fix?
the windsheild wiper trim piece is missing on the pass. side also so that may be where the water is coming from. there is no rust that i could find under the carpet.

other than that it just needs a basic tune-up , fluid flush, brakes bled and maybe pads , couple body/trim pieces and thats about it...

so its bye-bye to the piece of **** Celica.
Hello Blazer. :yumyum:

azbass
05-31-2007, 08:48 PM
omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg omg

sqhertz
05-31-2007, 08:51 PM
omg , omg.

xtremebassjunky
05-31-2007, 08:51 PM
I like mine.

I am about to post pics of my latest build in mine.

they get loud.

blackbonnie
05-31-2007, 08:53 PM
will wait for pics

sqhertz
05-31-2007, 08:53 PM
I like mine.

I am about to post pics of my latest build in mine.

they get loud.

pics ftw.
i love em. i had an 87 2-door that i wish i would of kept and built up, but didnt.
i already want to drop it 3" front and back and maybe some vette rims.

any ideas on the AC though?

Silver
05-31-2007, 10:51 PM
:) !

Picked it up today. ill have pics later tomorrow.
just a couple questions though...

AC works , just doesnt blow out the dash vents. just the defrost and foot vents. any reason/fix for this?
also the heat doesnt blow hot at all , it just stays cold. i was thinking heater core cause i found water on the passanger floor board but it doesnt smell like **** like how everyone says it does when the core takes a ****. reason/fix?
the windsheild wiper trim piece is missing on the pass. side also so that may be where the water is coming from. there is no rust that i could find under the carpet.

other than that it just needs a basic tune-up , fluid flush, brakes bled and maybe pads , couple body/trim pieces and thats about it...

so its bye-bye to the piece of **** Celica.
Hello Blazer. :yumyum:

ac could be bad control unit or actuator. heat doesnt blow... could be a bad control unit. do the windows fog up in the morning? also water on the floorboard could be coolant. does it have a sweet smell?

don't bleed the brakes, change pads 1st. Your pedal may be mushy due to worn pads. DO NOT top off brake fluid. dont touch anything untill pads are installed.

plus you can snap a bleeder screw and chances on a 96 are likely high.

enjoy your whip i always kinda liked the blazers. also if ur doing spark plugs be careful not to snap the plug off in the head. just beware that the car is old and treat it good. =)

sqhertz
06-01-2007, 12:01 AM
ac could be bad control unit or actuator. heat doesnt blow... could be a bad control unit. do the windows fog up in the morning? also water on the floorboard could be coolant. does it have a sweet smell?

don't bleed the brakes, change pads 1st. Your pedal may be mushy due to worn pads. DO NOT top off brake fluid. dont touch anything untill pads are installed.

plus you can snap a bleeder screw and chances on a 96 are likely high.

enjoy your whip i always kinda liked the blazers. also if ur doing spark plugs be careful not to snap the plug off in the head. just beware that the car is old and treat it good. =)


im not sure if the windows fog up, i picked it up today. the water smells like stagnant nasty water. not exactly sweet lol.
any way i could check the control unit myself?
the brakes dont feel mushy, but stiff. and stopping power isnt all there.


:)

xtremebassjunky
06-01-2007, 12:11 AM
pics ftw.
i love em. i had an 87 2-door that i wish i would of kept and built up, but didnt.
i already want to drop it 3" front and back and maybe some vette rims.

any ideas on the AC though?


Here ya go.
http://www.caraudio.com/forum/showthread.php?t=237723

I couldn't tell ya too much about the AC or Heat...

sqhertz
06-01-2007, 02:57 PM
anyone else have any idea about the AC situation?

Rich B
06-01-2007, 03:07 PM
anyone else have any idea about the AC situation?


I believe GM used a flex tubing for the ducts to the dash (kinda like a dryer vent hose) which is known to crack in the creases.

It may be as simple as you need new duct tubing, since you said it works on both the defroster vents and the floor vents.

Not very expensive if I remember correctly.

sqhertz
06-01-2007, 03:19 PM
ill check that out.
i was supposed to have pictures up by now , but its been raining all day. so im not sure when ill get around to cleaning/fixing it up.

regal8r
06-01-2007, 03:23 PM
could also be the passage door in the ducts that directs the air. as for the heat, its probably the heater core

sqhertz
06-01-2007, 05:32 PM
same problem my previous blazer had - open air vents. once this rain lets up im checking that out. last time it was a rust hole i just sanded and filled with silicone.
dont heater cores dump water all over the place when they go bad?

Silver
06-01-2007, 09:52 PM
same problem my previous blazer had - open air vents. once this rain lets up im checking that out. last time it was a rust hole i just sanded and filled with silicone.
dont heater cores dump water all over the place when they go bad?


yea and if it sits long enough it has a nasty *** smell. if your heat went out, chances are the core is bad.

have fun replacing that bish. last time i did one i pulled the dash and i had about 7 bolts left over.

=(

check your ducts also for the other problem. , but it also could be that actuator.

im beginning to think if the control unit was bad the defrost and floor would not work as well.

good luck.

cunokyle
06-01-2007, 09:56 PM
yea and if it sits long enough it has a nasty *** smell. if your heat went out, chances are the core is bad.

have fun replacing that bish. last time i did one i pulled the dash and i had about 7 bolts left over.

=(

check your ducts also for the other problem. , but it also could be that actuator.

im beginning to think if the control unit was bad the defrost and floor would not work as well.

good luck.

I just changed the one in my '94 this past fall...was a pain in the ***! I also had a few bolts left over as well! They are a pain to get to.

sqhertz
06-02-2007, 09:10 AM
so that liquid smell isnt coolant , right? ive read so much about the heater cores... im scared to even look at it , lol. but sooner or later it will get done. and there is no fogging on the windows...
any way to check the actuator?
im not mechanicaly inclined at all. so excuse my noobx-ness.

but i got some pics finally.

http://i95.photobucket.com/albums/l153/sqhertz/IMG_0243.jpg
missing bumper trim. ill probably hit up some junkyards and see what i can grab.
http://i95.photobucket.com/albums/l153/sqhertz/IMG_0244.jpg
http://i95.photobucket.com/albums/l153/sqhertz/IMG_0246.jpg
http://i95.photobucket.com/albums/l153/sqhertz/IMG_0245.jpg
floor is soaked with water. im almost postive its a leak in the open air vents or the gaurd that covers the windsheild wiper things to keep leaves and debris from getting in there.
first im going to wet-vac up all that water, rip out the insulation to prevent mold/mildew and go from there.
i will be posting pics of my progress as i get further along.

thanks for everyones help/suggestions. :)

THUNDERBIRD
06-02-2007, 09:33 AM
so if your not mechanically inclined i would take the truck to a mechanic and have them fix it for you, its gonna cost you. and for that wet carpet pull it out and order new carpet off of ebay for like $150 shipped and it is a drop in with a lil cutting.

connersdad19
06-02-2007, 09:45 AM
nice i like the blazer i am looking at getting one.....nice and roomy :fro:


did you check to see the seal around the windows as to the floor leaking?

sqhertz
06-02-2007, 09:57 AM
well i know enough to change spark plugs and **** like that but never changed a heater core or overhauled an engine. a few of my buddies are mechanics and ill most definatly have them check it out.
ima see if i can salvage the carpet before i drop money and order another one.
im getting arond to everythig today , since there is a little bit of sun comming through the clouds.

sqhertz
06-02-2007, 12:09 PM
welp , i just finished pulling the seat out and carpet up.
http://i95.photobucket.com/albums/l153/sqhertz/Blazer/IMG_0247.jpg
http://i95.photobucket.com/albums/l153/sqhertz/Blazer/IMG_0248.jpg
for now... im just going to wire brush that rust off and hit it with some of that rust-killing spray paint , or naval jelly if its bad , then seal it with some caulk.
im almost sure i found the leak, right behind this harness on the passanger kick.
http://i95.photobucket.com/albums/l153/sqhertz/Blazer/IMG_0252.jpg
http://i95.photobucket.com/albums/l153/sqhertz/Blazer/IMG_0251.jpg
bad spot to get a decent shot of it , but you can see the rust, theres also another small spot above that. im VERY picky about rust, i hate that ****.
there is this piece of rubber between the fender and , firewall (i guess) that im sure has some type of foam under it that i think is causing the leaks there. its full of leaves n tiny spiders that inhabit the truck, though alot of them got ****** up into the wet-vac. from the looks of where its at im probably going to have to take the fender off and rip that out and sand/seal it from the outside so it doesnt spread.

any suggestions/ better ideas?

sqhertz
06-02-2007, 03:30 PM
i went ahead sanded it down but instead of the rust paint , i just used naval jelly and some rubberized undercoat. i think itll work fine. theres still a tiny moisture on the metal that i didnt notice, so its taking forever to dry. also this weatehr isnt helping.

****** thing is, the spring on the hood latch ****ed up so i cant get the hood open. :verymad: ! soooo... i have to take the grill off and mess with the latch to get it open. f ucking spring.

xtremebassjunky
06-02-2007, 03:36 PM
looks like you got it rolling...

xtremebassjunky
06-02-2007, 03:36 PM
I have to give mine a bit of a bump on the hood sometimes...

sqhertz
06-02-2007, 04:55 PM
im sure its the spring. the guy i bought it from had problems getting it open, though i got it open real quick. i guess it finally went.