PDA

View Full Version : Eclipse CD5435???



aaronmiiller
05-18-2007, 11:50 PM
Just bought one, anybody own one of these units or know anything about them? Paid $130 for it, good buy? Thanks guys.

IgnoreMe
05-18-2007, 11:53 PM
its an eclipse...oh course its bomb

aaronmiiller
05-19-2007, 12:49 AM
LOL, i kinda figured, is that iserv navigation crap pretty helpful? Anyone mess with it any, hope this thing doesnt skip like my alpine at high spl levels?

IgnoreMe
05-19-2007, 01:06 AM
LOL, i kinda figured, is that iserv navigation crap pretty helpful? Anyone mess with it any, hope this thing doesnt skip like my alpine at high spl levels?

never used iserv. seems kinda lame. i guess i might as well try it someday but for now, my eclipse will just sit and play music. as long as you mount it firmly like it should, you shouldnt have any problems. my old alpine used to skip till my lazy *** decided to mount it correctly

aaronmiiller
05-19-2007, 02:45 PM
LOL, i have mine mounted VERY securely, it skips once in a great while, but thats my 9853, my 9831 NEVER skipped, not one time, both were mounted the same.

IgnoreMe
05-20-2007, 03:08 AM
LOL, i have mine mounted VERY securely, it skips once in a great while, but thats my 9853, my 9831 NEVER skipped, not one time, both were mounted the same.

my 9831 skipped like mad when it wasnt mounted great. mounted it better plus had it cleaned by alpine and repaired...worked for a while, started doing some gay ****, got jacked and thats the end of that one lol

2wheeler
05-20-2007, 11:34 AM
Ive had my 5435 for two years now, it's a solid unit. Never skipped, plays cds that are covered in scratches, tuner is average at pulling stations, SQ is great. Kinda ugly though...

aaronmiiller
05-21-2007, 04:10 PM
Good to hear^^^ Thanks man, i thought it looked pretty good? LOL, all i care about is it playing mp3 discs and not skipping. Thats all that matters to me in the end.