PDA

View Full Version : Rainbows Making Weird Sound...



chibahawk
05-01-2007, 10:04 PM
My SLC 265 Kick Bass comps were set with correct gains and have been butter up to this point. But today I was listening to some music in the morning and noticed a weird sound coming from my right speaker.


Everything seemed alright on low volume but as soon as I turned it up kind of loud my right speakers act up - on some hip-hop the 40s seem to need more power and I get a very flat response like a clap instead of the usual kick bass thud. Then on some horns on some chilli peppers the tweeter seems to maybe screech or something..


any idea?

soydeedo
05-02-2007, 02:05 AM
clipping?

Brad H.
05-02-2007, 08:22 AM
Check your right crossover.

chibahawk
05-02-2007, 05:26 PM
Yeah im gonna check my wiring when i get the chance. It's only the right speaker, only when the volume is high, and only on a certain frequency range (probably 40-90s maybe.

The midbass is the most notable sound its very flat like as if the speaker can't handle the bass.

3.5Max6spd
05-02-2007, 05:30 PM
what is your HP xover on the comps?

chibahawk
05-02-2007, 05:44 PM
had em cut off at 80... nows its 125 with no distortion on loud volume

3.5Max6spd
05-02-2007, 05:55 PM
what are you feeding them for power?

It sounds like you are bottoming them out/overdriving the speakers.

chibahawk
05-02-2007, 06:16 PM
theyre getting less than 100. cant remember exactly what i set them out. bottoming out sound about right but I dunno why it would all of a sudden happen considering they worked fine until a few days ago.

chibahawk
05-04-2007, 06:49 PM
ok i definitely need help here.. i took my right woofer out and put it on the left side and had the same problem. the speaker sounds great but when i turn the volume up and it tries to hit a low note with power - it makes a clap or crackle noise.

thinking it could be that the dust cap has removed itself somewhat and cant perform when being pounded. btw these were seeing way less than 100W each.