PDA

View Full Version : component wiring question



conecommander
04-11-2007, 12:42 AM
i have the MA Audio MA629C 6 1/2" component set.. my question is regarding the crossover. it has two inputs instead of one, which is different than other crossovers i have used in the past. i am running two component sets off a four channel amp, and running inputs to each tweeter and mid would leave a little short on available channels for my other two speakers. besides just splicing wires and running them to each input (which is how they are now) is there another way to wire these?

XanderMoser
04-11-2007, 01:20 AM
Did you read the manual? Maybe they just have two inputs to make it easier to connect a bridgeable amp...just a guess. Have you tried using just one of the inputs?

m4i2k2e2
04-11-2007, 01:21 AM
huh? ok do you mean you have an positive and negative for the amp. for the tweeter, and mid? there should be there own spot for each of these.
do you have a link to a pic of the crossover?

conecommander
04-11-2007, 01:45 AM
Did you read the manual? Maybe they just have two inputs to make it easier to connect a bridgeable amp...just a guess. Have you tried using just one of the inputs?

yes i tried only using the woofer and then only tweeter.. will not work unless there is an input to each.. manual shows a picture with a crossover with one input.. MA audio could spend a little more time on their manuals.. they don't do much for the user

conecommander
04-11-2007, 01:46 AM
huh? ok do you mean you have an positive and negative for the amp. for the tweeter, and mid? there should be there own spot for each of these.
do you have a link to a pic of the crossover?

here is a link to the component set

http://www.onlinecarstereo.com/CarAudio/ProductDetail.aspx?ProductID=14717

conecommander
04-11-2007, 10:38 PM
bump....

blklegend
04-13-2007, 10:34 PM
Could the 2 inputs be for biamp setup?