PDA

View Full Version : w00t! Just ordered my 880PRS



quakerroatmeal
03-05-2007, 01:34 PM
Yes yes I know, everyone has this thing. All the head-units I've owned has ALWAYS been Alpine. The current one I own and sold soon to send out after I get the 880prs is the CDA-9835, imo the best Alpine h-u ever made. But I'm just tired of Alpine. Hopefully the Pioneer Premier DEH-P880PRS gives good impression cause I'm picky! Brand new with 3 years extended warranty from onlinecarstereo for only 355$ shipped. I'll take pictures when I get it.

Prowler573
03-05-2007, 01:39 PM
Let's just hope OCS actually has it in stock. :crap:

quakerroatmeal
03-05-2007, 01:41 PM
Called them and checked just to make sure befor I ordered, called them checked, they have it and ordered over phone while at it. :)

hardhitta47
03-05-2007, 01:42 PM
Nice. I think you'll like it.

Prowler573
03-05-2007, 01:48 PM
Called them and checked just to make sure befor I ordered, called them checked, they have it and ordered over phone while at it. :)
Good call.
There have been entirely too many stories about them stonewalling people who order out-of-stock stuff and they just wait forever until it gets back in stock and never notify the customer of what's going on :crap:

quakerroatmeal
03-05-2007, 01:49 PM
Yeah that's what I was afraid of happening. I notice a few places had em out of stock. I wanted to call them first and if they didn't have em in stock I would of had to gone the ebay route. Good thing I didn't.

quakerroatmeal
03-09-2007, 01:28 AM
Lookie at what I received today!!.. :)

http://i48.photobucket.com/albums/f206/shyboy817/Box.jpg

quakerroatmeal
03-09-2007, 02:06 AM
Here's the pictures as I said.

http://i48.photobucket.com/albums/f206/shyboy817/880PRSBOX.jpg

http://i48.photobucket.com/albums/f206/shyboy817/880PRSBOX2.jpg

http://i48.photobucket.com/albums/f206/shyboy817/880PRS.jpg

http://i48.photobucket.com/albums/f206/shyboy817/880PRS2.jpg

champaned_out
03-09-2007, 02:19 AM
you'll love it, tons of options and a **** hu overall... im still learning new things about the hu everyday

One Bad MOFO
03-09-2007, 02:25 AM
:drool: :bowdown:

quakerroatmeal
03-09-2007, 02:27 AM
It's ****. It comes with a microphone for audio-adjustments. I've never seen this before. Pretty cool nonetheless! I'm already liking it!

One Bad MOFO
03-09-2007, 02:28 AM
It's ****. It comes with a microphone for audio-adjustments. I've never seen this before. Pretty cool nonetheless! I'm already liking it!
hows that work? do you just say like turn down the volume or something?

quakerroatmeal
03-09-2007, 02:32 AM
I don't think so. I think you use it to set your EQ's instead of listening to it by ear?. I'm not too certain. I still have to read the manual more.

Corollacrazy42
03-09-2007, 03:31 AM
Its for time alignment... I'm pretty sure

I think it senses and focuses the sound to be evenly matched to whereever the mic is...

quakerroatmeal
03-09-2007, 02:58 PM
I can't seem to find out where the internal amplifier on/off is in the multi-control? Where in the world is sub-out also? I haven't looked at the manual much but I feel it'd be easier for u guys to just tell me.

iceteebone
03-09-2007, 03:07 PM
hows that work? do you just say like turn down the volume or something?

lol no. you put the mic where your head is at in the car (headrest) and it uses that mic to automatically adjust eq and time alignment


I can't seem to find out where the internal amplifier on/off is in the multi-control? Where in the world is sub-out also? I haven't looked at the manual much but I feel it'd be easier for u guys to just tell me.

tunr the headunit off, press and hold multi-control and scroll through until you find the power amp option

quakerroatmeal
03-10-2007, 12:32 AM
Ah no wonder. Had to have the head-unit off. I seemed to took off the faceplate without pressing the button underneath the faceplate that releases it like twice. I don't think it did anything I hope not. Also I notice I have ground loop/whining noise now. Hmmm, I read somewhere that this was an issue with some defective 880prs?

Decipha
03-10-2007, 01:15 AM
my first 880 had a bad alt whine problem.. i sent it back and had a new one shipped that worked perfectly fine... hope u have a warranty on it.. im not sure if pioneer warrants online sales... anyway i would prefer the alpine 9833 over the 880... just my personal preference

baseballer1100
03-10-2007, 01:16 AM
****.

quakerroatmeal
03-10-2007, 01:19 AM
I have 3 years extended warranty on this badboy. **** I don't want to send this one back just yet. That's crappy. There's tons of settings I need to find. My sub-output seems low, and my highs seem low. I probably have to re-set the gains.

ajspellm
03-11-2007, 11:19 PM
my first 880 had a bad alt whine problem.. i sent it back and had a new one shipped that worked perfectly fine... hope u have a warranty on it.. im not sure if pioneer warrants online sales... anyway i would prefer the alpine 9833 over the 880... just my personal preference

there is no other way to fix that alternator whine? i am noticing it in my car with that head unit also. i just got it off ebay like a week ago. i bet they have a warranty but i would have to pay shipping or something for it

hardhitta47
03-11-2007, 11:52 PM
search it up.

others have had success with grounding the rca's to the deck

quakerroatmeal
03-12-2007, 12:42 AM
Grounding the RCA's to the deck? Well I finally got bothered because the **** alt whine got louder and bothered the living heck out of me. So I pulled it out and took off the ground, and re-grounded it to the chassis instead this time. I had it grounded through factory (which where my 9835 was grounded and had no whine). So far it stopped but I'm going to drive around and so forth to make sure its not there no more. If that doesn't work I'm going to try straight to battery, if that doesn't work I'm sending it back. So far its fine. I hope it doesn't come back.

j3bus2k3
03-12-2007, 12:44 AM
Grounding the RCA's to the deck? Well I finally got bothered because the **** alt whine got louder and bothered the living heck out of me. So I pulled it out and took off the ground, and re-grounded it to the chassis instead this time. I had it grounded through factory (which where my 9835 was grounded and had no whine). So far it stopped but I'm going to drive around and so forth to make sure its not there no more. If that doesn't work I'm going to try straight to battery, if that doesn't work I'm sending it back. So far its fine. I hope it doesn't come back.

Yes, ground the RCA's to the deck...

Theres a thread about it with some good pics and a good explanation...

krisfnbz
03-12-2007, 12:47 AM
lol $355 shipped thats a good price I guess if you wanted a warranty, ive seen em on ebay for $275 shipped, but then again I am an ebay freak. Nice head unit!

quakerroatmeal
03-12-2007, 12:52 AM
Yes, ground the RCA's to the deck...

Theres a thread about it with some good pics and a good explanation...

Can you show me a link to this thread?

And also to krisfnbz Lowest I've seen was around 290-300 shipped. I wanted to order from a known website. And 3 years extended warranty is nice. So really I have 4 years warranty for the head-unit.

adam71
03-12-2007, 07:37 AM
Can you show me a link to this thread?

And also to krisfnbz Lowest I've seen was around 290-300 shipped. I wanted to order from a known website. And 3 years extended warranty is nice. So really I have 4 years warranty for the head-unit.

If you grounded it to the chassis and it went away don't worry about grounding your RCA's. And if I'm not mistaken that cuts down on your voltage. I could be wrong though.

nismos14
03-13-2007, 01:48 PM
Are you running it active or passive?

bigbangtheory
03-14-2007, 08:10 PM
lol $355 shipped thats a good price I guess if you wanted a warranty, ive seen em on ebay for $275 shipped, but then again I am an ebay freak. Nice head unit!

I paid 215 for mine from a fellow ca.comer and havent had 1 problem with it.

It is a little difficult to get all the settings the way you will like them. Least that is my problem. Very nice deck though.

quakerroatmeal
03-15-2007, 02:41 AM
I'm running it passive at the moment. I have thought about running it active. But I'm having second thoughts. I have all the equipment to do so.

Ignatowski
03-15-2007, 05:51 AM
You should have bought an Excelon...........LOL

nismos14
03-15-2007, 08:06 AM
What second thoughts are you having?

krisfnbz
04-03-2007, 05:59 PM
Can you show me a link to this thread?

And also to krisfnbz Lowest I've seen was around 290-300 shipped. I wanted to order from a known website. And 3 years extended warranty is nice. So really I have 4 years warranty for the head-unit.

Well yeah if you want to order from a well known website your going to get ripped for your money. But whatever floats your boat. Take care of your equipment and it wont fail.

nismos14
04-03-2007, 06:50 PM
Well yeah if you want to order from a well known website your going to get ripped for your money. But whatever floats your boat. Take care of your equipment and it wont fail.

Doesn't matter how well you take care of it if it is defective from the factory.

quakerroatmeal
04-03-2007, 07:10 PM
Well so far the head-units working wonderful. No problems as of yet ever since I fixed the ground.