PDA

View Full Version : Why does my front speaker pop???



mountaineer
02-12-2007, 08:28 PM
I can't figure out why my front driverside speaker pops every time i get out my truck, it happens when i lift up off and take the weight the seat. I drive a 1997 mercury mountaineer the speakers are hooked up to a Xtant 400.4

Does anybody have any ideas what this could be??


THANKSSSS

jmanpc
02-12-2007, 08:29 PM
because you're gay

mountaineer
02-12-2007, 08:31 PM
you're mama

HannaS10
02-12-2007, 08:32 PM
maybe its not your speaker

tEh koRnDog
02-12-2007, 08:33 PM
+ - wires could be touching, wires could be touching door frame, mine does it and i know thats why, im just to lay to take the door panel off and cover up the wires

mountaineer
02-12-2007, 08:33 PM
What else could it be

mountaineer
02-12-2007, 08:35 PM
But i already checked all the wires and they look good i also took off the seat and stomped around but there was no pop

tEh koRnDog
02-12-2007, 08:36 PM
But i already checked all the wires and they look good i also took off the seat and stomped around but there was no pop

ok well you never mentioned that so forget that suggestion

azbass
02-12-2007, 08:37 PM
keep lookin, we cant tell you

mountaineer
02-12-2007, 08:37 PM
alright thanks

mountaineer
02-12-2007, 08:41 PM
Can it be a bad amp ground??

azbass
02-12-2007, 08:42 PM
who knows, we dont know how you grounded it.

mountaineer
02-12-2007, 08:48 PM
i sanded down the sheet metal under the back seat and used a metal frameing screw

azbass
02-12-2007, 08:51 PM
thats probably not it

azbass
02-12-2007, 08:51 PM
whats under the seat, that makes the pop?

mountaineer
02-12-2007, 08:53 PM
nothing is under the front seat

the727kid
02-12-2007, 08:55 PM
I had this problem with my Eclipse components, I set my PEQ 80hz all the way down and it went away.

mountaineer
02-12-2007, 08:55 PM
what i did was i ran wires from the amp to the speaker wiring harness behind the head unit and used the factory wires and speakers