PDA

View Full Version : Question on the grounding issue RE: Pio's



nismos14
02-05-2007, 11:11 AM
I'll be getting an 880prs here shortly, and wanted to find out if grounding the chassis of the unit itself would be a way to ensure that I don't run into the ground loop issues.

Basically if I use the bolt on the back of the heat sink and run a wire to a ground from there, do I need to ground the rca's to the HU chassis as well? Or would the chassis of the HU's ground take care of that?

chibahawk
02-05-2007, 01:34 PM
i think you only run one wire to the heat sink screw... im almost sure its just 3 wires total and only one to the chassis of the HU.

nismos... im just puttin my 880prs on the market, did you get rid of those rainbows?

nismos14
02-05-2007, 01:37 PM
Nope still have them, I'm keeping them, the midbass is too sick on them. I'm gonna get rid of the tweets though, and I should be running active within 2 months.

Hmm but the 880 has the adapter for the rca's, and then there are 3 sets of outputs.. so I'm not sure how to be sure to save myself of the issue.

chibahawk
02-05-2007, 01:44 PM
did you find the mini tutorial on the issue on the forums? gotta go to class now - ill check back later to see if i can help more



on a side note - before i sold my components, my engine noise had just come shrieking back - so my 880 is on my bad side as of now. it is amazing when it works tho.

chibahawk
02-05-2007, 01:45 PM
did you find the mini tutorial on the issue on the forums? gotta go to class now - ill check back later to see if i can help more



on a side note - before i sold my components, my engine noise had just come shrieking back - so my 880 is on my bad side as of now. it is amazing when it works tho.

nismos14
02-05-2007, 02:12 PM
did you find the mini tutorial on the issue on the forums? gotta go to class now - ill check back later to see if i can help more



on a side note - before i sold my components, my engine noise had just come shrieking back - so my 880 is on my bad side as of now. it is amazing when it works tho.

Yup I saw the tutorial however it shows it for the HU's with the preouts right on the HU I am just curious if I NEED to do it the same way with the 880, if so it's gonna kinda be a pita to do it.


Hmm engine noise with it huh? ****...


Edit : I find it funny that we can say ******* and **** on this forum but not d|amn...... lmao.

chibahawk
02-05-2007, 02:54 PM
Yup I saw the tutorial however it shows it for the HU's with the preouts right on the HU I am just curious if I NEED to do it the same way with the 880, if so it's gonna kinda be a pita to do it.


Hmm engine noise with it huh? ****...


Edit : I find it funny that we can say ******* and **** on this forum but not d|amn...... lmao.

the ground issue was fixed for a while by doing the stuff outlined in the tutorial... for a long time my set up was real nice but just recently the **** started buggin out and i was gettin engine noise again. it could be a different ground and not even related to the 880. my wiring is messy right now i gotta clean it up to see whats gooin on with the ground problem

nismos14
02-05-2007, 03:12 PM
So you just put wire around the ground sheild on each rca, and then bolted that to the chassis?